Snapecot
Contributor
Contributor

VM Workstation Player Wont Save Changes

I'll provide as many details as possible. My host computer is Windows 10

Using VM Workstation Player

Each of my 3 VM I have set up are each using 4GB RAM(plenty considering all 3 OS are really lightweight) and are 64 bit

Using Linux Mint XFce 20.2, CentOs 8.4.2105, and Lubuntu 20.04.3

Everywhere I go people say the 'default' is VM will save your changes. CentOS8 DOES save info no problem upon shutdown but the other 2 do not. Here are my multiple problems:

I boot up the first time with the downloaded ISO into a saved folder on my C: drive. VM Starts up, works just fine, make changes and play with the OS as much as I like, but when I shutdown, no data is saved.

If instead, I choose to reboot, it says 'no operating system found' when it tries to reboot.

so I close out of VM Player, I restart it(in admin mode as always), click power up within VM and it boots up like its the first time again, like the work I did previously has all been wasted.

Another issue is every time I 'shut down' or turn off a VM. The entire vmplayer shuts off. and I have to reopen the program. Its super annoying, Workstation Pro Never had any of these issues. You close a VM and it would take you back to the VM Home. 

Its driving me nuts. There are no settings to change this. People then tell me to change my VMX file to 'Keep' from 'autorevert' well I don't see either of those options anywhere. Here is my VMX file for Lubuntu:

Spoiler

.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "19"
mks.enable3d = "TRUE"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
nvram = "Lubuntu 64-bit.nvram"
virtualHW.productCompatibility = "hosted"
gui.exitOnCLIHLT = "FALSE"
powerType.powerOff = "soft"
powerType.powerOn = "soft"
powerType.suspend = "soft"
powerType.reset = "soft"
displayName = "Lubuntu 64-bit"
usb.vbluetooth.startConnected = "TRUE"
guestOS = "ubuntu-64"
tools.syncTime = "TRUE"
sound.autoDetect = "TRUE"
sound.fileName = "-1"
sound.present = "TRUE"
numvcpus = "2"
vcpu.hotadd = "TRUE"
memsize = "4096"
mem.hotadd = "TRUE"
scsi0.virtualDev = "lsilogic"
scsi0.present = "TRUE"
sata0.present = "TRUE"
scsi0:0.fileName = "Lubuntu 64-bit.vmdk"
scsi0:0.present = "TRUE"
sata0:1.deviceType = "cdrom-image"
sata0:1.fileName = "A:\School\IT Final Project\lubuntu-20.04.3-desktop-amd64.iso"
sata0:1.present = "TRUE"
usb.present = "TRUE"
ehci.present = "TRUE"
svga.graphicsMemoryKB = "8388608"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.virtualDev = "e1000"
serial0.fileType = "thinprint"
serial0.fileName = "thinprint"
ethernet0.present = "TRUE"
serial0.present = "TRUE"
extendedConfigFile = "Lubuntu 64-bit.vmxf"
floppy0.present = "FALSE"
uuid.bios = "56 4d 27 55 1f af 01 90-21 c4 8d 37 df f0 9e 13"
uuid.location = "56 4d 27 55 1f af 01 90-21 c4 8d 37 df f0 9e 13"
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
sata0.pciSlotNumber = "36"
svga.vramSize = "268435456"
vmotion.checkpointFBSize = "4194304"
vmotion.checkpointSVGAPrimarySize = "268435456"
vmotion.svga.mobMaxSize = "1073741824"
vmotion.svga.graphicsMemoryKB = "8388608"
vmotion.svga.supports3D = "1"
vmotion.svga.baseCapsLevel = "9"
vmotion.svga.maxPointSize = "1"
vmotion.svga.maxTextureSize = "16384"
vmotion.svga.maxVolumeExtent = "2048"
vmotion.svga.maxTextureAnisotropy = "16"
vmotion.svga.lineStipple = "0"
vmotion.svga.dxMaxConstantBuffers = "14"
vmotion.svga.dxProvokingVertex = "0"
vmotion.svga.sm41 = "1"
vmotion.svga.multisample2x = "1"
vmotion.svga.multisample4x = "1"
vmotion.svga.msFullQuality = "1"
vmotion.svga.logicOps = "1"
vmotion.svga.bc67 = "9"
vmotion.svga.sm5 = "1"
vmotion.svga.multisample8x = "1"
vmotion.svga.logicBlendOps = "1"
ethernet0.generatedAddress = "00:0c:29:f0:9e:13"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "-537879021"
monitor.phys_bits_used = "45"
cleanShutdown = "FALSE"
softPowerOff = "FALSE"
usb:1.speed = "2"
usb:1.present = "TRUE"
usb:1.deviceType = "hub"
usb:1.port = "1"
usb:1.parent = "-1"
svga.guestBackedPrimaryAware = "TRUE"
tools.remindInstall = "TRUE"
tools.upgrade.policy = "upgradeAtPowerCycle"
usb:0.present = "TRUE"
usb:0.deviceType = "hid"
usb:0.port = "0"
usb:0.parent = "-1"

Moderator edit by wila: Moved the vmx file contents into a spoiler

Please any help and insights would be appreciated. I need professional assistance. 

 

0 Kudos
3 Replies
RDPetruska
Leadership
Leadership


@Snapecot wrote:

I'll provide as many details as possible. My host computer is Windows 10

Using VM Workstation Player

Each of my 3 VM I have set up are each using 4GB RAM(plenty considering all 3 OS are really lightweight) and are 64 bit

Using Linux Mint XFce 20.2, CentOs 8.4.2105, and Lubuntu 20.04.3

Everywhere I go people say the 'default' is VM will save your changes. CentOS8 DOES save info no problem upon shutdown but the other 2 do not. Here are my multiple problems:

 

Another issue is every time I 'shut down' or turn off a VM. The entire vmplayer shuts off. and I have to reopen the program. Its super annoying, Workstation Pro Never had any of these issues. You close a VM and it would take you back to the VM Home. 

That is the behavior of the Player UI - to close when the VM is shut down.

As far as the rest, it sounds like you created a non-persistent virtual hard disk.

0 Kudos
Snapecot
Contributor
Contributor

How do I change that? Please I need help as this is for a school project. How can I make changes so it saves all my data for these two VMs?

0 Kudos
Snapecot
Contributor
Contributor

Can Someone please assist me in providing an answer? 

0 Kudos