Contributor
Contributor

Two Bridged Network interfaces

Hi,

I'm running VMWare Player 3.0.0 build-203739 on Red Hat Enterprise Linux 4 on a machine that has 2 physical network interfaces (eth0, eth1)

I want to have bridged access to these interfaces in my virtual machines, but when I create two virtual adapters they both get an ip from the eth0 interface.

How do I map the second virtual interface to eth1?

/etc/vmware/networks looks like this:

answer VNET_0_INTERFACE eth0

answer VNET_1_INTERFACE eth1

Thanks

Tags (3)
0 Kudos
4 Replies
Immortal
Immortal

Can you post your .vmx config file for the virtual machine with the two virtual NICs?

Since you didn't mention any VM configuration, I would first suggest that you check VM Settings in the UI. For the two virtual NIC devices, there is a UI control to select which virtual network the virtual adapter should use. You will want to set each NIC to use a virtual network that is bridged to a specific host adapter (as opposed to just auto-bridged). Modifying virtual network configuration can be done with the vmnetcfg UI.

Sorry for the brevidy; I can provide more details if needed.

Thanks.

0 Kudos
Contributor
Contributor

My VMX looks like this:

.encoding = "UTF-8"

config.version = "8"

virtualHW.version = "7"

numvcpus = "2"

maxvcpus = "4"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "512"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Ubuntu.vmdk"

ide1:0.present = "TRUE"

ide1:0.fileName = "auto detect"

ide1:0.deviceType = "cdrom-raw"

floppy0.fileType = "device"

floppy0.fileName = ""

floppy0.clientDevice = "FALSE"

ethernet0.present = "TRUE"

ethernet0.wakeOnPcktRcv = "FALSE"

ethernet0.addressType = "generated"

usb.present = "TRUE"

ehci.present = "TRUE"

sound.present = "TRUE"

sound.fileName = "-1"

sound.autodetect = "TRUE"

mks.enable3d = "FALSE"

pciBridge0.present = "TRUE"

pciBridge4.present = "TRUE"

pciBridge4.virtualDev = "pcieRootPort"

pciBridge4.functions = "8"

pciBridge5.present = "TRUE"

pciBridge5.virtualDev = "pcieRootPort"

pciBridge5.functions = "8"

pciBridge6.present = "TRUE"

pciBridge6.virtualDev = "pcieRootPort"

pciBridge6.functions = "8"

pciBridge7.present = "TRUE"

pciBridge7.virtualDev = "pcieRootPort"

pciBridge7.functions = "8"

vmci0.present = "TRUE"

roamingVM.exitBehavior = "go"

displayName = "Ubuntu"

guestOS = "ubuntu"

nvram = "Ubuntu.nvram"

virtualHW.productCompatibility = "hosted"

gui.exitOnCLIHLT = "FALSE"

extendedConfigFile = "Ubuntu.vmxf"

ethernet0.generatedAddress = "00:0c:29:dc:62:52"

uuid.location = "56 4d 43 b6 fe 28 bf bc-c1 c8 f9 ec 4f dc 62 52"

uuid.bios = "56 4d 43 b6 fe 28 bf bc-c1 c8 f9 ec 4f dc 62 52"

cleanShutdown = "TRUE"

replay.supported = "FALSE"

replay.filename = ""

scsi0:0.redo = ""

pciBridge0.pciSlotNumber = "17"

pciBridge4.pciSlotNumber = "21"

pciBridge5.pciSlotNumber = "22"

pciBridge6.pciSlotNumber = "23"

pciBridge7.pciSlotNumber = "24"

scsi0.pciSlotNumber = "16"

usb.pciSlotNumber = "32"

ethernet0.pciSlotNumber = "33"

sound.pciSlotNumber = "34"

ehci.pciSlotNumber = "35"

vmci0.pciSlotNumber = "36"

vmotion.checkpointFBSize = "16777216"

ethernet0.generatedAddressOffset = "0"

vmci0.id = "1339843154"

floppy0.autodetect = "TRUE"

ide1:0.autodetect = "TRUE"

checkpoint.vmState = "Ubuntu.vmss"

ide1:0.startConnected = "FALSE"

tools.syncTime = "TRUE"

debugStub.linuxOffsets = "0x0,0xffffffff,0x0,0x0,0x0,0x0,0x0,0x0,0x0,0x0,0x0,0x0,0x0,0x0"

ethernet1.pciSlotNumber = "37"

ethernet1.present = "TRUE"

ethernet1.wakeOnPcktRcv = "FALSE"

ethernet1.addressType = "generated"

ethernet1.generatedAddress = "00:0c:29:dc:62:5c"

ethernet1.generatedAddressOffset = "10"

ethernet1.startConnected = "TRUE"

isolation.tools.hgfs.disable = "FALSE"

unity.wasCapable = "TRUE"

floppy0.startConnected = "FALSE"

ide0:0.present = "FALSE"

In my UI (VMPLayer 3.0) there is no option to select which virtual interface the virtual adapters should choose.

Thanks

0 Kudos
Immortal
Immortal

your vmx-file is completely mis-configured - don't know why ???

anyway - remove move all ethernet entries and replace them with this ones

ethernet0.present= "true"

ethernet0.startConnected = "true"

ethernet0.virtualDev = "e1000"

ethernet0.connectionType = "custom"

ethernet0.vnet = "vmnet0"

ethernet1.present= "true"

ethernet1.startConnected = "true"

ethernet1.virtualDev = "e1000"

ethernet1.connectionType = "custom"

ethernet1.vnet = "vmnet2"

also do not assign vmnet1 to a physical nic - it should be left to the default which is hostonly

so change

answer VNET_1_INTERFACE eth1

to

answer VNET_2_INTERFACE eth1

___________________________________

VMX-parameters- VMware-liveCD - VM-Sickbay

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
Contributor
Contributor

I made the changes you proposed (Don't know why the file was so messed up, I only used the gui to change things) The first virtual network now works but the second one can't be connected.

I think this is because there is no vmnet2 running (I did restart the vmware service)

sudo vmware-networks --status

Bridge networking on vmnet0 is running

Network detection service is not running

All the services configured on all the networks are running

After adding

add_bridge_mapping eth0 0

add_bridge_mapping eth1 2

to /etc/vmware/networks things are running ok.

Thanks a lot for your help!

0 Kudos