lawleagle
Contributor
Contributor

Stop VMWare from using port 443.

Jump to solution

How do I disable sharing or change port sharing is using? It is using port 443 and I need that port for something else! I'm using VMWare Workstation 12 Player.

Thank you.

0 Kudos
1 Solution

Accepted Solutions
bdpEMC-spam
Contributor
Contributor

Try this:

On a Windows command prompt:

netstat -ano | find ":443" | find "LISTENING"

The last column is the process id that is listening on that port.

or on Linux:

lsof -nP | grep :443

The first column should be process name and 2nd column the PID. Cna do a "ps auxwww | grep xxxx" to see more details on that PID


You can start task manager to see what process it is - may need to enable the Process ID/PID column.

This KB mentions how to change sharing port on full Workstation, not sure sharing exists on player as I haven't used Player:

https://kb.vmware.com/kb/2005585

View solution in original post

0 Kudos
6 Replies
rcporto
Leadership
Leadership

Go to menu Edit -> Preferences -> Shared VMs and click on "Disable Sharing".

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
lawleagle
Contributor
Contributor

I found this fix a lot on the internet, but I figured it's for an old version of VMWare. My VMWare has no menu (and sequentially no "Edit")!

http://image.prntscr.com/image/c3b7422ee2ae4780a48b9016160526f5.png

0 Kudos
rcporto
Leadership
Leadership

You're opening the VMware Workstation 12 Player. Do you have the VMware Workstation Pro installed?

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
lawleagle
Contributor
Contributor

I did state in my original question that I'm using the "Player" version. It may have it installed, but it certainly isn't activated:

http://image.prntscr.com/image/9441e0d1ef1946fb91eb32f9d8c240e0.png

I don't own the pro version.

0 Kudos
bdpEMC-spam
Contributor
Contributor

Try this:

On a Windows command prompt:

netstat -ano | find ":443" | find "LISTENING"

The last column is the process id that is listening on that port.

or on Linux:

lsof -nP | grep :443

The first column should be process name and 2nd column the PID. Cna do a "ps auxwww | grep xxxx" to see more details on that PID


You can start task manager to see what process it is - may need to enable the Process ID/PID column.

This KB mentions how to change sharing port on full Workstation, not sure sharing exists on player as I haven't used Player:

https://kb.vmware.com/kb/2005585

0 Kudos
lawleagle
Contributor
Contributor

There was a vmware process that I killed in order to stop vmware from using that port, but I thought it was temporary. I restarted to check, and I was right, that process got started again. After I killed it again, I could use that port for my own needs.

Thank you for the "find" instructions. When I checked the first time, I checked by looking on my own. Now, with that process killed, I restarted the machine, and to my surprise that vmware process did not start (sorry I can't name the process from my head). So for now, I'll mark this question as "Solved". Instead, now I get that process with PID=4 uses that port, and I can't use that port myself at all now, because process with PID=4 is the System process.

Thank you for your help.


PS: That video does not apply to "Player" version.

0 Kudos