VMware Communities
mobidutch
Contributor
Contributor
Jump to solution

Shared folder not working - W11 host / Ubuntu 22.04 guest / Open VM Tools

I am using VMWare Workstation 16 Player on a Windows 11 Home host. I installed Open VM tools into my Ubuntu Desktop 22.04 guest. I added a shared folder for the guest in the VMWare Workstation 16 Player user interface with the option "Always enabled', and the vmx file now contains the following entries:

isolation.tools.hgfs.disable = "FALSE"
sharedFolder0.present = "TRUE"
sharedFolder0.enabled = "TRUE"
sharedFolder0.readAccess = "TRUE"
sharedFolder0.writeAccess = "TRUE"
sharedFolder0.hostPath = "D:\VMs\Shared"
sharedFolder0.guestName = "Shared"
sharedFolder0.expiration = "session"
sharedFolder.maxNum = "1"

When I boot the VM and navigate to the folder /mnt/hgfs, I do see the folder /mnt/hgfs/shared. But placing anything in that folder on either host or guest does not show up on the other side.

What am I missing here?

Reply
0 Kudos
1 Solution

Accepted Solutions
Technogeezer
Immortal
Immortal
Jump to solution

There is a known issue that impacts Linux guests that you might be running into. The symptom is that shared folders do not mount automatically at boot, and do not persist across reboots of the virtual machine should you mount them manually.

The standard documented workaround is to disable and enable the Shared Folders feature of the VM from the GUI while the guest operating system is running. However, this work-around is not persistent, and must be repeated after each reboot of the VM.

A persistent solution is to edit /etc/fstab in the Linux guest and add an entry to mount the shared folders automatically on boot. As an example, adding the following line to /etc/fstab will mount shared folders at boot time:

vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0


Another persistent solution for distributions using systemd can be found in the following VMware Knowledge Base article: https://kb.vmware.com/s/article/74650

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides

View solution in original post

9 Replies
fredbhh
Contributor
Contributor
Jump to solution

Hi mobidutch, 

i have the same values and trouble. 

Did you solve it?

 

Best regards,

fredbhh

Reply
0 Kudos
Technogeezer
Immortal
Immortal
Jump to solution

There is a known issue that impacts Linux guests that you might be running into. The symptom is that shared folders do not mount automatically at boot, and do not persist across reboots of the virtual machine should you mount them manually.

The standard documented workaround is to disable and enable the Shared Folders feature of the VM from the GUI while the guest operating system is running. However, this work-around is not persistent, and must be repeated after each reboot of the VM.

A persistent solution is to edit /etc/fstab in the Linux guest and add an entry to mount the shared folders automatically on boot. As an example, adding the following line to /etc/fstab will mount shared folders at boot time:

vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0


Another persistent solution for distributions using systemd can be found in the following VMware Knowledge Base article: https://kb.vmware.com/s/article/74650

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
mobidutch
Contributor
Contributor
Jump to solution

The solution provided by Technogeezer worked for me!  <thumbs up>

Reply
0 Kudos
fredbhh
Contributor
Contributor
Jump to solution

Hey there, 

thanks for your fast reply!

Unfortunatley, this still does not work for me. 

Disable / Enable shared folders haven`t any effect just like adding

"vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0"

to /etc/fstab. And it doesn`t matter, if i try opening shared folders immediatley or reboot first. 

Do you keep previous lines in the /etc/fstab file?

In my case, this has been the final result:

"GNU nano 6.2 /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda3 during installation
UUID=ae358bbb-ee14-4386-9c0e-65836bd339ca / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda2 during installation
UUID=B25E-9AE4 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0
vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0"

Do you know, if "ext4 errors=remount-ro 0 1" has any effect on my problem?

I`m grateful for any help!

Best regards, 

fredbhh

Reply
0 Kudos
fredbhh
Contributor
Contributor
Jump to solution

P.S.

Now i followed the complete instruction https://kb.vmware.com/s/article/74650

and have windows-network in the files-folder, but only as empty folder and no rights to write, create or change this directory

Reply
0 Kudos
mobidutch
Contributor
Contributor
Jump to solution

I am by no means an expert in Unix/Linux, and I am afraid I don't have any tips on what may be wrong. You have the exact same entries in /etc/fstab as I do (other than the UUIDs). Sorry I can't be of more help!

Reply
0 Kudos
Technogeezer
Immortal
Immortal
Jump to solution


@fredbhh wrote:

Hey there, 

thanks for your fast reply!

Unfortunatley, this still does not work for me. 

Disable / Enable shared folders haven`t any effect just like adding

"vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0"

to /etc/fstab. And it doesn`t matter, if i try opening shared folders immediatley or reboot first. 

Do you keep previous lines in the /etc/fstab file?

In my case, this has been the final result:

"GNU nano 6.2 /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda3 during installation
UUID=ae358bbb-ee14-4386-9c0e-65836bd339ca / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda2 during installation
UUID=B25E-9AE4 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0
vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0"

Do you know, if "ext4 errors=remount-ro 0 1" has any effect on my problem?


What Linux distro/version are you running?

Have you verified that open-vm-tools are installed? 

One thought. Does the directory /mnt/hgfs exist in your VM? If not sudo to root and create the directory. 

The other entries and options in the fstab file don’t have any impact on this  in fact do not touch any other entries in the fstab file lest you risk introducing problems starting your VM  

 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
fredbhh
Contributor
Contributor
Jump to solution

but thank you anyway!

 

Reply
0 Kudos
fredbhh
Contributor
Contributor
Jump to solution

Its Ubuntu 22.04 -64 bit Lts in a VMWare Workstation 15 Player on Windows

The /mnt/hgfs folder exits with

" dr-xr-xr-x 1 root root 0 Jun 14 15:52 'sharedfolder_Ubuntu 22.04 64-bit Freetz' " 

in it.

And open-vmware-tools are def. already installed. 

I have no idea, what went wrong ...

 

 

Reply
0 Kudos