Highlighted
Enthusiast
Enthusiast

Setting the default directory for VMs

Jump to solution

Using VMware Player 3, how can I set the default directory for virtual machines to be opened and/or created?

Regards

Marius

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Immortal
Immortal

Open your user's preference file (On Windows, %APPDATA%\VMware\preferences.ini).

You want to add OR modify the following line:

- prefvmx.defaultVMPath =

If that key is not in the file, add it and set the right side to the full path you want as the default,

- prefvmx.defaultVMPath = "C:\Thanksgiving\Ate\Too\Much"

Now that Player can create VMs, it would be nice to have UI to specify the default directory to put/get those VMs Smiley Happy

View solution in original post

5 Replies
Highlighted
Immortal
Immortal

Open your user's preference file (On Windows, %APPDATA%\VMware\preferences.ini).

You want to add OR modify the following line:

- prefvmx.defaultVMPath =

If that key is not in the file, add it and set the right side to the full path you want as the default,

- prefvmx.defaultVMPath = "C:\Thanksgiving\Ate\Too\Much"

Now that Player can create VMs, it would be nice to have UI to specify the default directory to put/get those VMs Smiley Happy

View solution in original post

Highlighted
Enthusiast
Enthusiast

I looked for the %APPDATA%\VMware\preferences.ini but I was unable to locate it on my Windows XP PC running VMware Player version 3.0.0 build-203739.

I looked at the registry as well but I was unable to locate any key with a similar name.

I create a file %APPDATA%\VMware\preferences.ini and inserted the line you suggest, but it looks to be ignored.

Maybe the hint is related to an earlier version of VMware Player, or I am missing some relevant point?

Regards

Marius

0 Kudos
Highlighted
Immortal
Immortal

Oops, I think you need to use %USERPROFILE%\Application Data\VMware\preferences.ini.

Highlighted
Enthusiast
Enthusiast

It works!

I was a little bit surprised because entries in the file start with pref.view. but it works as suggested.

Regards

Marius

0 Kudos
Highlighted
Contributor
Contributor

Even after changing the path, mine refused to work until I installed VIX after which it detected the GNS3 VM

0 Kudos