Mentyth
Contributor
Contributor

Poor performance after update with message about side channel mitigation

Jump to solution

I was asked to upgrade my VM ware player today. I clicked yes and the updater ran and asked for a restart.

This actually completely removed my installed vmware player!!

I downloaded the latest version and installed that but get this  message:

You are running this virtual machine with side channel mitigations enabled. Side channel mitigations provide enhanced security but also lower performance.

To disable mitigations, change the side channel mitigations setting in the advanced panel of the virtual machine settings. Refer to VMware KB article 79832 at  URL for more details.

 

However the instructions don't say how to do this on vmware player.

0 Kudos
1 Solution

Accepted Solutions
bluefirestorm
Champion
Champion

That message about disabling side channel mitigations shows up only when the ULM is used instead of the ring 0 VMM as the hypervisor monitor. That means the Windows host has been detected to have Hyper-V enabled.

https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

There is no advanced options in VMware Workstation Player. To disable the side channel mitigation, shut down the VM and add the following to the VM vmx configuration file.

ulm.disableMitigations = "TRUE"

View solution in original post

4 Replies
bluefirestorm
Champion
Champion

That message about disabling side channel mitigations shows up only when the ULM is used instead of the ring 0 VMM as the hypervisor monitor. That means the Windows host has been detected to have Hyper-V enabled.

https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

There is no advanced options in VMware Workstation Player. To disable the side channel mitigation, shut down the VM and add the following to the VM vmx configuration file.

ulm.disableMitigations = "TRUE"

View solution in original post

RobSentel
Contributor
Contributor

I updated VMWare Player to 16.

After that the performance decreased until it was impossible to use VMWare.

I tried to adjust the setting by entering the line: ulm.disableMitigations = "TRUE". Did not work, I tried ulm.enableMitigations = "FALSE". NOTHING.

I don't have Hyper-V installed on Windows 10. The problem was solved"????

Performance is poor and makes using VMWare Player impossible.

Perhaps the solution is to roll back the previous version of the software.

The problem was NOT SOLVED, is now a Critical Problem,

0 Kudos
RaSystemlord
Expert
Expert

@RobSentel 

I don't know about this Hyper-V issue, but looking for other things.

What is your guest VM and what are you driving there, if meaningful for the slowness to appear? What is your Host hardware? (processor, ram) What is your Windows 10 version (like 2004, or something)? Have you done (or let Microsoft to do) any Feature Upgrade after installing VMware?

Can you share your settings for the VM? 

... this should be in another thread since, as you say, this looks different to the topic of this discussion.

0 Kudos
RobSentel
Contributor
Contributor

The recomendation works: ulm.disableMitigations = "TRUE"

But when I started a VM, the VMWare window freeze.
To unfreeze I need to minimize and maximize the VMWare Window.

After that the performance was ok.
Thanks

 

 

Tags (1)
0 Kudos