Highlighted
Contributor
Contributor

Poor performance after update with message about side channel mitigation

Jump to solution

I was asked to upgrade my VM ware player today. I clicked yes and the updater ran and asked for a restart.

This actually completely removed my installed vmware player!!

I downloaded the latest version and installed that but get this  message:

You are running this virtual machine with side channel mitigations enabled. Side channel mitigations provide enhanced security but also lower performance.

To disable mitigations, change the side channel mitigations setting in the advanced panel of the virtual machine settings. Refer to VMware KB article 79832 at  URL for more details.

 

However the instructions don't say how to do this on vmware player.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Virtuoso
Virtuoso

That message about disabling side channel mitigations shows up only when the ULM is used instead of the ring 0 VMM as the hypervisor monitor. That means the Windows host has been detected to have Hyper-V enabled.

https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

There is no advanced options in VMware Workstation Player. To disable the side channel mitigation, shut down the VM and add the following to the VM vmx configuration file.

ulm.disableMitigations = "TRUE"

View solution in original post

1 Reply
Highlighted
Virtuoso
Virtuoso

That message about disabling side channel mitigations shows up only when the ULM is used instead of the ring 0 VMM as the hypervisor monitor. That means the Windows host has been detected to have Hyper-V enabled.

https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

There is no advanced options in VMware Workstation Player. To disable the side channel mitigation, shut down the VM and add the following to the VM vmx configuration file.

ulm.disableMitigations = "TRUE"

View solution in original post