VMware Communities
HisWill
Contributor
Contributor

Please help using vmrun with VMware Workstation 16 Player

Hello all.  I've been using VMware Player 16.1.2 along with the VIX API 1.17.  Everything works just fine, my vmrun commands control my Windows 7 Pro VM just how I'd expect.  However, when I updated to VMware Player 16.2.1, my vmrun commands no longer work properly.  I can start up my VM using vmrun, but vmrun seems to lose the connection to my VM somehow.  If anyone has any insight to share, it would be greatly appreciated.  Thanks.

Specifics

VMware-Player-16.1.2-17966106.x86_64.bundle + VMware-VIX-1.17.0-6661328.x86_64.bundle = works great

VMware-Player-16.2.1-18811642.x86_64.bundle + VMware-VIX-1.17.0-6661328.x86_64.bundle = does not work

2 Replies
wila
Immortal
Immortal

Hi,


@HisWill wrote:
 I can start up my VM using vmrun, but vmrun seems to lose the connection to my VM somehow.

Can you be more specific.
Is there an error message, screen shot?

Have you tried rebooting the host?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
fabio_brizzolla
Enthusiast
Enthusiast

Hi, I have the exact same problem. After updating to VMware-player from 16.1.2 to 16.2.3, VMware-vix 1.17 seems to lost connection with the vm it had started. I receive back, after a timeout of approximately 1,5min, a code 255. 

 

This is the result of vmware-install -l:

Product Name Product Version
==================== ====================
vmware-vix 1.17.0.6661328
vmware-player 16.2.3.19376536

 

The command executed is:

/usr/bin/vmrun -T player start '/home/niumar/vmware/GNS3 VM/GNS3 VM.vmx'
Error: Cannot connect to the virtual machine

echo $?

255

0 Kudos