Micheal2
Contributor
Contributor

Opensuse Leap 15.3 as Guest in VMware

I installed Opensuse Leap 15.3( server install) in workstation player 16. Everything is fine, but from the start I only get the minimum size of guest. Already a problem is reported  https://forums.opensuse.org/showthread.php/523100-Opensuse-guest-in-VMWare-can-t-get-full-screen but it had a desktop environment and they did something with xrandr but without xorg in my guest I can't do anything! I also have open vm tools to its latest version! Since my guest comes only with a command line, what should I do?

Tags (3)
0 Kudos
21 Replies
ajgringo619
Enthusiast
Enthusiast

Your problem is completely different than the one in the link you referenced. Of course, you can't get a full screen...because there's no Xorg running! When you installed, did you select a desktop environment?
0 Kudos
ajgringo619
Enthusiast
Enthusiast

Were you presented an install option like this:opensuse-tw-server.jpg

If so, you'll need to install a desktop environment as none of the Xorg/DE packages were installed

 

 

0 Kudos
Micheal2
Contributor
Contributor

Yes, I installed with that option! Is there no way to get full screen other than installing desktop environments?

0 Kudos
ajgringo619
Enthusiast
Enthusiast

OK, I got this working on my test server. All of the following is done on the VM:

  1. Edit /etc/default/grub, find the entry "GRUB_GFXMODE="
  2. Change it to the resolution you want. On my system, I used "GRUB_GFXMODE=1920x1080x32" as I run that mode natively.
  3. Run grub2-mkconfig -o /boot/grub2/grub.cfg (as root), then reboot

If your resolution doesn't work, you will need to access the GRUB menu by hitting "C" after selecting the default boot entry. From here, run videoinfo to get a list of all the recognized resolutions.

0 Kudos
Micheal2
Contributor
Contributor

Its not working, I tried keeping your resolution nothing ,then in grub terminal I  ran videoinfo and picked a resolution(720x576x32) but also no success. Another issue I ran into is I cannot view all resolution in grub terminal since its so small and outputs ran fast. Is there a similar pipe command ( | ) for grub like  [videoinfo | less]. What should I do now?

0 Kudos
RaSystemlord
Hot Shot
Hot Shot

Don't know the answer for the original question, but I guess server environment is limited to some terminal resolutions, like those from VT 100-terminal. If you have more, then its up to the server OS itself to give them.

Why don't you use your Host capabilities (like magnification) to enlarge your terminal window? Not sure what those capabilities are in each Host OS. Obviously, this doesn't give a better resolution.

I understand that there are Linux server distros, but what is the point in using them? Server concept dates back to decades when graphical terminal were very expensive and there were not Remote Desktop capabilities. Surely a better performance of a bare-bone Linux cannot be a real reason, or is it? Perhaps ultra-security-requirement, might be a reason?

0 Kudos
Micheal2
Contributor
Contributor

I am using windows 10, not sure is there any host capability to zoom. For servers the more package you include the more chance it will be exploited. GUI is not available for server due to security reasons.

0 Kudos
ajgringo619
Enthusiast
Enthusiast

720x576 is a really small resolution. What size is your monitor? Mine above matches what the physical monitor displays.

You can also change the console font size; the GFXMODE only enlarges the console window.
0 Kudos
Micheal2
Contributor
Contributor

Yes its a small resolution, Just needed to verify the available resolution of videoinfo ( Since output ran too fast, I can just only see around 10) . My laptop is 15.6 inch FHD.  I used Windows 10 and Fedora with 1920x1080 with no issues. I don't think changing resolution or scaling will solve the issue, because the command line is itself in the middle of screen if I set to full screen in my vmware, First I need to work to bring it to left corner, then increase pixel and need to scale around 150%. I think its the way!? Check out the image I uploaded,! in question.What should I do now?

0 Kudos
ajgringo619
Enthusiast
Enthusiast

Your image looks exactly like my screen before I made the GRUB changes. First thing I noticed after a reboot was the splash screen expanded to take up the whole window.
0 Kudos
Micheal2
Contributor
Contributor

The only difference I can see when changed from 720x576 to 1920x1980 is the grub menu when kept in high resolution shows opensuse theme if its set to low, shows a black theme in boot entry. Nothing other than that. My grub file in /etc/default/

# If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
# /boot/grub2/grub.cfg.

# Uncomment to set your own custom distributor. If you leave it unset or empty, the default
# policy is to determine the value from /etc/os-release
GRUB_DISTRIBUTOR=
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=8
GRUB_CMDLINE_LINUX_DEFAULT="splash=silent mitigations=auto quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to automatically save last booted menu entry in GRUB2 environment

# variable `saved_entry'
# GRUB_SAVEDEFAULT="true"
#Uncomment to enable BadRAM filtering, modify to suit your needs

# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
# GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
#Uncomment to disable graphical terminal (grub-pc only)

GRUB_TERMINAL="gfxterm"
# The resolution used on graphical terminal
#note that you can use only modes which your graphic card supports via VBE

# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1920x1080x32"
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
# GRUB_DISABLE_LINUX_UUID=true
#Uncomment to disable generation of recovery mode menu entries

# GRUB_DISABLE_RECOVERY="true"
#Uncomment to get a beep at grub start

# GRUB_INIT_TUNE="480 440 1"
GRUB_BACKGROUND=
GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
SUSE_BTRFS_SNAPSHOT_BOOTING="true"
GRUB_DISABLE_OS_PROBER="false"
GRUB_ENABLE_CRYPTODISK="n"
GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16"

What am I missing?

 

0 Kudos
ajgringo619
Enthusiast
Enthusiast

The only difference that stands out is I use Linux Mint for the host, but I doubt that's a factor here. Maybe you can enable OpenSSH server on the guest and come in that way, expand your terminal however you like.
0 Kudos
Micheal2
Contributor
Contributor

That is a way, How did you download the opensuse iso, The network Image or offline image and What is your firmware of VMware BIOS or UEFI? I will try once again with a install.!

0 Kudos
ajgringo619
Enthusiast
Enthusiast

I downloaded the offline image. All of my VMs use UEFI, which is easy to setup if you select Other Linux 5.x and later kernel 64-bit instead of whatever VMware detects the OS from the ISO.

0 Kudos
Micheal2
Contributor
Contributor

I tried booting by UEFI but encountered some issues, I checked online documentations but most of them are different, Finally I edited my .vmx file and added firmware="efi" after that I cant boot. I will attach the image in link and when I load the VM it shows side-channel mitigations enabled! Is that a cause,? I am using VMware workstation player 16 (Non commercial Version)  https://imgur.com/a/NO5mpzO 

0 Kudos
ajgringo619
Enthusiast
Enthusiast

In order to add EFI that way, you need to first create a VM but do NOT install it. Configure all of your settings, make the edit, then boot into the installation ISO. Adding UEFI afterwards is not going to work.
0 Kudos
Micheal2
Contributor
Contributor

I think I narrowed the issue, I created a VM without the iso file then edited the .vmx file and added firmware="efi" then went through the installing process , first I got small screen then I made changes to grub file and rebooted and I got full screen like you said. Then I shutdown  guest and after sometime when I started,  I got the same issue but when I checked the .vmx file my changes were overwritten like firmware="bios". Why this occurs ? Is it like only pro should use UEFI?

0 Kudos
ajgringo619
Enthusiast
Enthusiast

This was how I used to add the UEFI option in Player before I bought a license of Workstation. Did the VM even boot afterwards?
0 Kudos
Micheal2
Contributor
Contributor

I checked the vmx file by doing another install, Ignore my last post, turns out that efi is added to the middle of the file, and when I add another firmware="efi" weird things started to happen. Thing is, its like a one time, got full screen only one time after updating grub and rebooting guest.I will attach the vmx file and I am tired of troubleshooting. I am thinking of another server distribution, maybe with Fedora??

 

.encoding = "windows-1252"
config.version = "8"
virtualHW.version = "18"
mks.enable3d = "TRUE"
pciBridge0.present = "TRUE"
pciBridge4.present = "TRUE"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "TRUE"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "TRUE"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "TRUE"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
vmci0.present = "TRUE"
hpet0.present = "TRUE"
nvram = "OpenSUSE 64-bit.nvram"
virtualHW.productCompatibility = "hosted"
gui.exitOnCLIHLT = "FALSE"
powerType.powerOff = "soft"
powerType.powerOn = "soft"
powerType.suspend = "soft"
powerType.reset = "soft"
displayName = "OpenSUSE 64-bit"
usb.vbluetooth.startConnected = "TRUE"
guestOS = "opensuse-64"
tools.syncTime = "FALSE"
sound.autoDetect = "TRUE"
sound.fileName = "-1"
sound.present = "TRUE"
numvcpus = "4"
vcpu.hotadd = "TRUE"
memsize = "4096"
mem.hotadd = "TRUE"
scsi0.virtualDev = "lsilogic"
scsi0.present = "TRUE"
scsi0:0.fileName = "OpenSUSE 64-bit.vmdk"
scsi0:0.present = "TRUE"
ide1:0.deviceType = "cdrom-image"
ide1:0.fileName = "C:\Users\demo\Downloads\openSUSE-Leap-15.3-DVD-x86_64-Current.iso"
ide1:0.present = "TRUE"
usb.present = "TRUE"
ehci.present = "TRUE"
svga.graphicsMemoryKB = "8388608"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.virtualDev = "e1000"
serial0.fileType = "thinprint"
serial0.fileName = "thinprint"
ethernet0.present = "TRUE"
serial0.present = "TRUE"
extendedConfigFile = "OpenSUSE 64-bit.vmxf"
floppy0.present = "FALSE"
firmware="efi"
uuid.bios = "56 4d b8 25 1b 1d 0f 64-32 0e 7e ae b0 b9 07 80"
uuid.location = "56 4d b8 25 1b 1d 0f 64-32 0e 7e ae b0 b9 07 80"
scsi0:0.redo = ""
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "16"
usb.pciSlotNumber = "32"
ethernet0.pciSlotNumber = "33"
sound.pciSlotNumber = "34"
ehci.pciSlotNumber = "35"
vmci0.pciSlotNumber = "36"
svga.vramSize = "268435456"
vmotion.checkpointFBSize = "4194304"
vmotion.checkpointSVGAPrimarySize = "268435456"
vmotion.svga.mobMaxSize = "1073741824"
vmotion.svga.graphicsMemoryKB = "8388608"
vmotion.svga.supports3D = "1"
vmotion.svga.baseCapsLevel = "9"
vmotion.svga.maxPointSize = "1"
vmotion.svga.maxTextureSize = "16384"
vmotion.svga.maxVolumeExtent = "2048"
vmotion.svga.maxTextureAnisotropy = "16"
vmotion.svga.lineStipple = "0"
vmotion.svga.dxMaxConstantBuffers = "14"
vmotion.svga.dxProvokingVertex = "0"
vmotion.svga.sm41 = "1"
vmotion.svga.multisample2x = "1"
vmotion.svga.multisample4x = "1"
vmotion.svga.msFullQuality = "1"
vmotion.svga.logicOps = "1"
vmotion.svga.bc67 = "9"
vmotion.svga.sm5 = "1"
vmotion.svga.multisample8x = "1"
vmotion.svga.logicBlendOps = "1"
ethernet0.generatedAddress = "00:0c:29:b9:07:80"
ethernet0.generatedAddressOffset = "0"
vmci0.id = "-1330051200"
monitor.phys_bits_used = "45"
cleanShutdown = "TRUE"
softPowerOff = "TRUE"
usb:1.speed = "2"
usb:1.present = "TRUE"
usb:1.deviceType = "hub"
usb:1.port = "1"
usb:1.parent = "-1"
svga.guestBackedPrimaryAware = "TRUE"
guestOS.detailed.data = "bitness='64' distroName='openSUSE Leap' distroVersion='15.3' familyName='Linux' kernelVersion='5.3.18-57-default' prettyName='openSUSE Leap 15.3'"
usb:0.present = "TRUE"
usb:0.deviceType = "hid"
usb:0.port = "0"
usb:0.parent = "-1"

0 Kudos