VMware Communities
steffk85
Contributor
Contributor
Jump to solution

Not able to activate 3D acceleration for Win10 guest system

Hi,

I'm running VMware Workstation 17 Player on a Kubuntu host. When I try to activate the 3D acceleration for my Windows 10 guest system it will instantly crash while booting.

There are possible solutions in other threads, I tried to set these settings in the vmx file (I can't find a config.ini on my system):

 

mks.enableX11Presentation=FALSE
mks.enableVulkanPresentation=TRUE

 

but nothing helps....VMWare Version:

 

VMware® Workstation 17 Player
17.0.1 build-21139696

 

My system:

 

Operating System: TUXEDO OS 2
KDE Plasma Version: 5.27.2
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.1.0-1009-tuxedo (64-bit)
Graphics Platform: X11
Processors: 20 × 12th Gen Intel® Core™ i7-12700H
Memory: 62.6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 (NVIDIA Driver Version: 525.85.05)
Manufacturer: TUXEDO
Product Name: TUXEDO InfinityBook Pro Gen7 (MK2)

 

Do I have to put those settings in another file? Am I at the wrong location? Or do I have to write it in another syntax because of the linux system?

Please help, I really need 3D acceleration in this system

Tags (4)
Reply
0 Kudos
1 Solution

Accepted Solutions
brianp201110141
VMware Employee
VMware Employee
Jump to solution

Try adding mks.vk.forceDevice="NVIDIA" to your ~/vmware/VMNAME/*.vmx file.

We've improved the GPU selection code for a future release.

 

View solution in original post

Reply
0 Kudos
3 Replies
brianp201110141
VMware Employee
VMware Employee
Jump to solution

Try adding mks.vk.forceDevice="NVIDIA" to your ~/vmware/VMNAME/*.vmx file.

We've improved the GPU selection code for a future release.

 

Reply
0 Kudos
steffk85
Contributor
Contributor
Jump to solution

Wow, that worked immediately! Thank you so much!

Just for my info: why are you adding params in a vmx-config file which I can't set in the gui? This was a very important parameter for me....I don't get it....

Reply
0 Kudos
brianp201110141
VMware Employee
VMware Employee
Jump to solution

Choosing the right Vulkan device/driver should "just work" but in multi-GPU systems there are some subtleties (we examine device IDs, driver version numbers, etc).  Also, there are external methods (like the VK_ICD_FILENAMES env var and perhaps the vkconfig tool) which can be used to select the GPU for any Vulkan application.

Like I said, we've improved this for a future release and you shouldn't need the vmx setting then.  Sorry for the inconvenience.

 

Reply
0 Kudos