Latrina25
Contributor
Contributor

No option for 'Guest Isolation' in VMware Workstation 16 player

Hi,

I was trying to solve the issue of not being able to copy and paste from my windows 10 PC to the virtual Ubuntu 18.04 CLI.

I found out i should enable it in Guest Isolation tab in options but I do not have such thing in my menu (as you can see in the screenshot below).

pastedImage_0.png

I should have the VMware tools installed so I'm not sure what the problem is.

pastedImage_2.png

6 Replies
a_p_
Leadership
Leadership

Not sure about the Ubuntu CLI, but these settings should be enabled by default.

The following settings (in the VM's .vmx file)  are only required to disable them.

isolation.tools.dnd.disable = "TRUE"

isolation.tools.copy.disable = "TRUE"

isolation.tools.paste.disable = "TRUE"

André

Latrina25
Contributor
Contributor

Thank you for your reply ! I'm not sure if I'm looking at the wrong file but I don't seem to have those options in my file.

pastedImage_1.png

0 Kudos
a_p_
Leadership
Leadership

Yes, you're looking at the wrong file. The .vmx file is the one above the .vmxf file.

You can disable "Hide file extensions .." in the Windows Exploerer's settings.

André

Latrina25
Contributor
Contributor

I see, i don't know how i missed that i thought i checked every file.. nvm
Well I added those lines in the file since they were missing completely but I'm still not able to copy and paste text between my PC and the VM

0 Kudos
scott28tt
VMware Employee
VMware Employee

You set the 3 disable options to TRUE or to FALSE?

They need to be FALSE and you should only make the change with Workstation closed.

0 Kudos
Latrina25
Contributor
Contributor

I tried both while the VM Workstation was closed.

0 Kudos