Bryan29556
Contributor
Contributor

No Sound

I have no sound in my guest OS but sound works fine in my host OS

I am using ubuntu as my guest os and windows xp pro as my host

also using VMware Player

This is just to get the problem out there... I am happy to provide any other info if needed Smiley Happy

Message was edited by:

Bryan29556

0 Kudos
10 Replies
RDPetruska
Leadership
Leadership

Have you added an audio adapter to your guest? By default I don't think it is added. If you have added it, have you installed a driver for it? The virtual audio adapter is a Creative Labs Sound Blaster AudioPCI device.

0 Kudos
KevinG
Immortal
Immortal

Post the .vmx file from yout virtual machine

0 Kudos
Bryan29556
Contributor
Contributor

Thanks for replying; I don't excactly know how to add an audio adapter, however here is the requested post of the .vmx file:

#!/usr/bin/vmware

config.version = "8"

virtualHW.version = "4"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "256"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Ubuntu-6.06.1-desktop-i386.vmdk"

scsi0:0.writeThrough = "TRUE"

ide1:0.present = "TRUE"

ide1:0.fileName = "auto detect"

ide1:0.deviceType = "atapi-cdrom"

floppy0.startConnected = "FALSE"

floppy0.fileName = "/dev/fd0"

Ethernet0.present = "TRUE"

displayName = "Ubuntu-6.06.1-desktop-i386"

guestOS = "ubuntu"

priority.grabbed = "normal"

priority.ungrabbed = "normal"

powerType.powerOff = "hard"

powerType.powerOn = "hard"

powerType.suspend = "hard"

powerType.reset = "hard"

scsi0:0.redo = ""

ethernet0.addressType = "generated"

uuid.location = "56 4d e6 51 35 5e 5c 75-73 4c ba be 89 c4 b8 11"

uuid.bios = "56 4d e6 51 35 5e 5c 75-73 4c ba be 89 c4 b8 11"

ethernet0.generatedAddress = "00:0c:29:c4:b8:11"

ethernet0.generatedAddressOffset = "0"

ide1:0.autodetect = "TRUE"

uuid.action = "create"

tools.remindInstall = "TRUE"

ide1:0.startConnected = "TRUE"

tools.syncTime = "FALSE"

checkpoint.vmState = ""

0 Kudos
KevinG
Immortal
Immortal

Hi Bryan,

Your virtual machine does not have a virtual sound adapter in the virtual machine configuration file (.vmx)

With the virtual machine powered off, try adding the following lines to the end of the .vmx file

sound.present = "TRUE"

sound.virtualDev = "es1371"

sound.fileName = "-1"

sound.autodetect = "TRUE"

This requires that have a physical sound card installed in your host.

Once the guest is booted, you may have to install the SoundBlaster PCI 128 sound driver for Ubuntu

0 Kudos
RDPetruska
Leadership
Leadership

Since you're on a Windows host, you may want to check out my VMX Builder/editor program. See my profile for website.

Rob

0 Kudos
Bryan29556
Contributor
Contributor

thanks everyone that seems to have solved the problem

0 Kudos
gramsay
Contributor
Contributor

Hello,

I am using VMware Player

Host = Windows XP Pro

Guest = Ubuntu 6.0.6 Dapper Drake

Problem = no sound card found, hence no sound ....

My .vmx file is:

#!/usr/bin/vmware

config.version = "8"

virtualHW.version = "4"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "256"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Ubuntu-6.06.1-desktop-i386.vmdk"

scsi0:0.writeThrough = "TRUE"

ide1:0.present = "TRUE"

ide1:0.fileName = "auto detect"

ide1:0.deviceType = "atapi-cdrom"

floppy0.startConnected = "FALSE"

floppy0.fileName = "/dev/fd0"

Ethernet0.present = "TRUE"

displayName = "Ubuntu-6.06.1-desktop-i386"

guestOS = "ubuntu"

priority.grabbed = "normal"

priority.ungrabbed = "normal"

powerType.powerOff = "hard"

powerType.powerOn = "hard"

powerType.suspend = "hard"

powerType.reset = "hard"

scsi0:0.redo = ""

ethernet0.addressType = "generated"

uuid.location = "56 4d 0a 97 54 32 ec 9e-42 35 ac 68 0c 81 33 06"

uuid.bios = "56 4d 0a 97 54 32 ec 9e-42 35 ac 68 0c 81 33 06"

ethernet0.generatedAddress = "00:0c:29:81:33:06"

ethernet0.generatedAddressOffset = "0"

ide1:0.autodetect = "TRUE"

uuid.action = "create"

tools.remindInstall = "FALSE"

ide1:0.startConnected = "TRUE"

tools.syncTime = "FALSE"

===================================================

I can add the lines:

sound.present = "TRUE"

sound.virtualDev = "es1371"

sound.fileName = "-1"

sound.autodetect = "TRUE"

to the .vmx files.

but i dont understand the following about installing the sound card when in guest.

How is that done ?

Thanks,

GR

0 Kudos
gramsay
Contributor
Contributor

ok, after adding those few lines to the .vmx file and rebooting the guest Ubuntu, the sound works now.

Thanks much .....

But funny how this was is no documentation I could find.

Did I do something wrong during the install ?

Also if I had to manually add those lines for the soundcard, will there be other configuration issues for Ubuntu for other features I should know/plan for.

Thanks,

GR

0 Kudos
beerorkid
Contributor
Contributor

OK now the opposite.

ubuntu host, XP vm, no sound.

the error when I start the VM is:

/dev/dsp: Device or resource busy. will start disconnected

VMX:

#!/usr/bin/vmware

config.version = "8"

virtualHW.version = "4"

scsi0.present = "TRUE"

memsize = "256"

ide0:0.present = "TRUE"

ide0:0.fileName = "Windows XP Professional.vmdk"

ide0:0.writeThrough = "TRUE"

ide1:0.present = "TRUE"

ide1:0.fileName = "/dev/hda"

ide1:0.deviceType = "cdrom-raw"

sound.present = "TRUE"

sound.virtualDev = "sb16"

sound.fileName = "-1"

sound.autodetect = "TRUE"

floppy0.fileName = "/dev/fd0"

Ethernet0.present = "TRUE"

displayName = "Windows XP Professional"

guestOS = "winxppro"

priority.grabbed = "normal"

priority.ungrabbed = "normal"

powerType.powerOff = "hard"

powerType.powerOn = "hard"

powerType.suspend = "hard"

powerType.reset = "hard"

autostart = "none"

snapshot.disabled = "TRUE"

ide0:0.redo = ""

ide1:0.startConnected = "TRUE"

ethernet0.addressType = "generated"

uuid.location = "56 4d e2 b0 c5 7d 91 9b-a1 59 59 62 34 bf 8e bb"

uuid.bios = "56 4d e2 b0 c5 7d 91 9b-a1 59 59 62 34 bf 8e bb"

ethernet0.generatedAddress = "00:0c:29:bf:8e:bb"

ethernet0.generatedAddressOffset = "0"

tools.syncTime = "TRUE"

checkpoint.vmState = ""

sound.deviceNr = "-1"

sound.device = "/dev/dsp"

0 Kudos
doom9
Contributor
Contributor

I'm running VMware Player version 2.0.2 build 59824

My host OS is Windows XP Pro

My Guest OS is gentoo 2.6.22-r8

I have my vmx file configured properly. I've installed ALSA, and the appropriate kernel modules.

Gentoo seems to think it's playing audio, but i'm not hearing anything.

It's like it's not being passed through by VMware.

Here's my .vmx:

#!/usr/bin/vmplayer

config.version = "8"

virtualHW.version = "4"

guestOS = "other26xlinux"

displayName = "r2d2"

annotation = "R2D2"

guestinfo.vmware.product.long = "Gentoo - 2.6.22-r8"

guestinfo.vmware.product.url = "http://www.gentoo.org"

guestinfo.vmware.product.class = "virtual machine"

numvcpus = "1"

memsize = "512"

MemAllowAutoScaleDown = "FALSE"

MemTrimRate = "-1"

uuid.action = "create"

tools.remindInstall = "TRUE"

hints.hideAll = "TRUE"

tools.syncTime = "TRUE"

usb.present = "TRUE"

usb.generic.autoconnect = "FALSE"

serial0.present = "TRUE"

serial0.fileName = "Auto Detect"

serial0.autodetect = "TRUE"

serial0.hardwareFlowControl = "TRUE"

serial1.present = "FALSE"

parallel0.present = "TRUE"

parallel0.fileName = "Auto Detect"

parallel0.autodetect = "TRUE"

parallel0.bidirectional = "TRUE"

sound.present = "TRUE"

sound.virtualDev = "es1371"

sound.fileName = "-1"

sound.autodetect="TRUE"

logging = "TRUE"

log.fileName = "r2d2.log"

log.append = "TRUE"

log.keepOld = "1"

isolation.tools.hgfs.disable = "FALSE"

isolation.tools.dnd.disable = "FALSE"

isolation.tools.copy.enable = "TRUE"

isolation.tools.paste.enabled = "TRUE"

ethernet0.present = "TRUE"

ethernet0.virtualDev = "e1000"

ethernet0.connectionType = "nat"

ethernet0.addressType = "generated"

ethernet0.generatedAddressOffset = "0"

ethernet1.present = "TRUE"

ethernet1.virtualDev = "e1000"

ethernet1.connectionType = "bridged"

ethernet1.addressType = "generated"

ethernet1.generatedAddressOffset = "10"

floppy0.present = "FALSE"

ide1:0.present = "TRUE"

ide1:0.deviceType = "cdrom-raw"

ide1:0.startConnected = "TRUE"

ide1:0.fileName = "auto detect"

ide1:0.autodetect = "TRUE"

ide0:0.present = "TRUE"

ide0:0.fileName = "r2d2.vmdk"

ide0:0.mode = "persistent"

ide0:0.startConnected = "TRUE"

ide0:0.writeThrough = "TRUE"

ide0:1.present = "TRUE"

ide0:1.fileName = "r2d2-2.vmdk"

ide0:1.mode = "persistent"

ide0:1.startConnected = "TRUE"

ide0:1.writeThrough = "TRUE"

extendedConfigFile = "r2d2.vmxf"

virtualHW.productCompatibility = "hosted"

tools.upgrade.policy = "manual"

ethernet0.generatedAddress = "00:0c:29:29:4f:1b"

ethernet1.generatedAddress = "00:0c:29:29:4f:25"

uuid.location = "56 4d 60 0e 15 f4 6d 95-2d fa a2 20 26 29 4f 1b"

uuid.bios = "56 4d 60 0e 15 f4 6d 95-2d fa a2 20 26 29 4f 1b"

ide0:0.redo = ""

ide0:1.redo = ""

checkpoint.vmState = ""

parallel0.startConnected = "FALSE"

Any suggestions fellow gentoo'ers?

0 Kudos