Hummy123
Contributor
Contributor

Multiple monitors not working with vmware workstation player 16

Hi,

with latest vmware workstation player 15 version I could create ubuntu 20.04 VM, install open-vm-tools-deskop and use multiple monitors of my host.

With player 16 that is not possible anymore. Nothing happens if I select another option, the VM remains running on just one display. Within the VM, I can also see only 1 display.

This is reproducible with latest vmware workstation player 16, Windows 10 1809 and Ubuntu 20.04 as guest.

12 Replies
Hummy123
Contributor
Contributor

An update:

I have a laptop connected to two external displays (through a docking station).

If I disable the laptop display in windows settings, (so that only the two external displays are used) then using both displays seems to work in the VM.

FYI I did try to set the laptop display on the same "height" as the other two in the display settings, that did not help.

So currently if I want to use two displays in the VM I need to disable the laptop display...

0 Kudos
ankurdubey521
Contributor
Contributor

Facing the exact same issue with similar observations. Cycle through multiple displays simply does nothing when two external monitors asre connected, but works well when only one external monitor is connected

0 Kudos
Racle90
Contributor
Contributor

Same problem here.
I'm using 3 monitors. With workstation player 15 they worked just fine.

0 Kudos
jayaarkay
Contributor
Contributor

I have a similar issue with Workstation 16 Pro. My workstation grade laptop, running Windows 10, is connected to 3 monitors. The laptop screen is off/closed all the time. Out of the  3 monitors I use 2 for my Ubuntu VM. With Workstation 15 Pro I had no issues with this setup, but after upgrading to 16 Pro the layout keeps switching, every few minutes, to use just one monitor.

0 Kudos
FranzMatze
Contributor
Contributor

Same here. I use a Dell XPS 15 with a Docking Station and two additional screens. However, I cannot use more than one screen with VMware Player 16. This was working with VMware Player 15 before upgrading.

0 Kudos
jayaarkay
Contributor
Contributor

Also, for me the "monitor layout" button is grayed out, giving an impression that it is disabled, even though I can click it and choose a layout; which then keeps switching on me anyway.

0 Kudos
jayaarkay
Contributor
Contributor

Here is the a screenshot...

pastedImage_0.png

0 Kudos
CoNetrix
Contributor
Contributor

I am also having this issue where my monitor layout arbitrarily switches from 2 monitors back to a  single monitor. I did not have this problem with Workstation version 15.  I am running various Windows desktops and servers as guest on a Windows 10 (10.0.19041.630  a.k.a 2020H2)  O/S on a Lenovo P1 laptop.

0 Kudos
darksidemaze
Contributor
Contributor

Did any of the contributors on here, ever get a resolution?

 

Seeing similar problems ie 2 monitors work, with single cycle monitor button in the toolbar but 3+ monitors show the popup window layout window and selecting one of the layouts doesnt many any changes.

0 Kudos
darksidemaze
Contributor
Contributor

0 Kudos
RockyRodrigo
Contributor
Contributor

Hi,

I'm having the same issue, (vmware workstation 16)multi monitor switches back to a single monitor. Can't find anything that triggers it.

Any Solution?

0 Kudos
vsixs
Contributor
Contributor

Same issue here, almost a year later nothing changed.

Tried different OS settings and tweaks on Ubuntu, openSUSE, Fedora, Debian. Didn't help.

Installed VMWare Workstation Player 15, worked well with multiple monitors. A few days later it auto-updated to version 16 and multiple monitors stopped working again.

Dear vmware, if you can't fix the issue, at least give me an option to use an older version which did what I wanted it to do.

0 Kudos