Highlighted
Contributor
Contributor

Modified computer

I have replaced the motherboard in my computer and now have solid state drive.

I still have the old HD installed in the machine as the F drive.

I can load the VMPlayer but it doesn't find the virtual machine or the SW I had on it.

What do I need to do to get going again?

0 Kudos
14 Replies
Highlighted
Virtuoso
Virtuoso

Assuming the old HD was simply assigned as F drive in the new motherboard and you had used default locations for VMs in the previous motherboard, the VMs should now be in

F:\Users\<your previous user name>\Documents\Virtual Machines

You may have to grant administrative privileges when you navigate to that folder in Windows Explorer.

0 Kudos
Highlighted
Contributor
Contributor

This enabled me to find the old virtual machines (I had set up 3 which are essentially the same). However, when I tried to use them I get the error: "Error while powering on: Internal error"

0 Kudos
Highlighted
User Moderator
User Moderator

There could be several reasons for this.

  • check whether all VMware services are up, and running
  • in case the VMs were suspended, you may need to reset them (delete their .vmss files)
  • if there are any .lck files, or folders in the VM's home folders, delete them

André

0 Kudos
Highlighted
Contributor
Contributor

I did not find any .vmss or .lck for the virtual machine.

I do not see any obvious VM services. I have the following starting with the letter V.

pastedImage_1.png

0 Kudos
Highlighted
User Moderator
User Moderator

Did you reinstall VMware Player, or are you trying to launch it from the "old" F: drive?

Simply starting the old executable won't work.

André

0 Kudos
Highlighted
Contributor
Contributor

Ok. I reinstalled the program and it runs but I cannot print. I recall having to do something previously to set up printing. Can you point me to the instructions?

Thanks,

Gary

0 Kudos
Highlighted
Contributor
Contributor

I get a message that says (something like) the device ID is out of range for your system. It goes by quick.

Specifically dealing with printing, I get the message:

"The virtual printing feature is globally disabled on this system, and will not

be enabled for this virtual machine.

Failed to connect virtual device 'serial 0'."

I am printing through a network. I tested it and it is working from with underlying windows 10 OS.

0 Kudos
Highlighted
User Moderator
User Moderator

Not sure about that. Would you mind to attach the VM's latest vmware.log file to a reply post? Maybe it contains some hints.


André

0 Kudos
Highlighted
Contributor
Contributor

I have attached the log file.

0 Kudos
Highlighted
Virtuoso
Virtuoso

You can go to "Player" menu, "File" -> "Preferences" and check the "Enable virtual printers". There is a "Change Settings" button you need to click so that you can check the "Enable virtual printers".

If you don't want to use virtual printing, you would require to install the corresponding printer drivers and setup the printer inside the VM just as you would if it were a physical machine.

0 Kudos
Highlighted
Contributor
Contributor

I followed these instructions and I was able to print a test page. So far so good. However, I am now having problems with the application I have installed in VMWare. It seemed to be working fine before enabling the printing.

I have a VM running XP. The application is Corel Ventura 10 which will not run under more recent Operating Systems. Now when I try to run Ventura, the buttons in the software are generally unresponsive and except for a bit of luck in printing the test page, I have been having problems.

0 Kudos
Highlighted
Virtuoso
Virtuoso

I am not familiar with Corel Ventura. Rightfully with your current setup, the XP VM will have DX9 capability (assuming Corel Ventura can take advantage of DX9). Looking at the vmware.log that you attached previously, it looks like you have an Intel i5-8400 CPU, Nvidia GT710 GPU and the virtual hardware version is set to 10.

You could try changing the virtual hardware version to 16 (the maximum supported by version Player 15.0.2). This might help in the responsiveness of the graphics inside the VM. But with such an old OS and old application, it cannot really take advantage of the new CPU features and newer graphics capabilities.

Shutdown the VM, and edit vmx configuration file and change the line

virtualHW.version = "10"

to

virtualHW.version = "16"

It is better to have a backup of the VM created before you edit this.

0 Kudos
Highlighted
Contributor
Contributor

I don't see this file. Where is it?

0 Kudos
Highlighted
User Moderator
User Moderator

In the folder where your VM files are stored.  Do yourself a favor (if you haven't already) and disable the "hide file extensions for known types" in Windows Explorer options.

0 Kudos