gcare
Contributor
Contributor

Micosoft Teams black screen when sharing

I am using VMWare Player 16 with Windows 10 20H2 host and guest and latest Office components including Microsoft Teams, with Hyper-V.

When sharing a PowerPoint file (not the screen or the PowerPoint window, the file sharing functionality), each slide will show for a moment when changing page and then disappears leaving the screen as black. I have tested both when sharing starts from another user or when I am sharing the content from my VM. All the other functionalities (webcam display, screen sharing, etc.) work correctly. I don't have any other issues with the other programs I have tested up to now (mainly Office and web browsing).

If a run with the same OS configuration, but with a VM directly on Hyper-V, everything works correctly, both with the advanced session connection and RDP.

I am not sure if this is an issue with Microsoft Teams or VMWare, but it seems anyway to be connected with the interaction of that SW with the display driver used by VMWare. The timings of the slide becoming black change, sometimes it starts to be black only in part of the slide. Seems an issue related to caching of the shown bitmap that gets lost somehow.

Does someone know any workaround to solve this issue?

Tags (2)
0 Kudos
1 Reply
gcare
Contributor
Contributor

I found a solution: disable the display HW acceleration in Microsoft Teams. I had to do the same in PowerPoint by the way, as I discovered that there were some small issues in displaying slides also there.

It seems that the emulated display driver of VMware still needs some bug fixing... Not sure if the same issues are present without Hyper-V or are related to this specific configuration.

0 Kudos