VMware Communities
raywood
Enthusiast
Enthusiast

How to go online in VM while host is offline

I am running an Ubuntu 20.04 VM on a Windows 10 host. I would like to be able to go online in the VM while the host is offline. I have attached a USB WiFi adapter to the guest. The host is using a different WiFi adapter. But if I take the host offline, the guest goes offline too. What am I doing wrong?

0 Kudos
13 Replies
leijonamieli
Enthusiast
Enthusiast

Is the guest WiFi adapter turned on in the VM window and connected?

Have you tried disabling other network connections of the VM?

0 Kudos
raywood
Enthusiast
Enthusiast

Guest WiFi adapter: Player > Removable Devices shows a checkmark next to the WiFi adapter, and an option to Disconnect.

I don't know that the VM has any network connections other than the NAT or Bridged options I have tried in Settings.

0 Kudos
leijonamieli
Enthusiast
Enthusiast

I mean disconnecting the Network Adapter that is used to connect through the host.

 

0 Kudos
raywood
Enthusiast
Enthusiast

Sorry, I'm not sure I understand. I have tried connecting to the Internet, from inside the VM, with no WiFi adapters connected to the computer other than the one that is attached to the VM. Is that what you mean?

0 Kudos
leijonamieli
Enthusiast
Enthusiast

Please take a screenshot of your VM Settings -> Hardware.

 

I attached one of mine to show what I mean.

0 Kudos
raywood
Enthusiast
Enthusiast

OK, here (Windows 10 host):

 

0 Kudos
a_p_
Leadership
Leadership

I'm confused. You said that you've attached (passed through) the USB stick to the VM. So why do you have an additional virtual network adapter configured?

The way your setup should work is to remove/disable the virtual NAT adapter in the VM's settings, and only use the passed through WiFi adapter with an in-guest driver.

André

0 Kudos
raywood
Enthusiast
Enthusiast

I did look for an option that said something like "None of the above" after the Bridged, NAT etc. options.

I think you mean the "Connected" and "Connect at power on" boxes should not be checked. That makes sense to me. But if I uncheck them, there's no Internet access.

I have two different USB WiFi dongles plugged into the host system. Either of them works for taking the host system online. Neither works for taking the VM online if the VM's "Connected" and "Connect at power on" boxes are unchecked.

0 Kudos
bluefirestorm
Champion
Champion

You probably need the internet access to get the drivers for the USB WiFi device into the VM. Once you get the USB WiFi drivers installed and up and running in the VM, you should be able to leave the "Connect at Power On" unchecked. It is hard to say how to test that it is working as usually two active NICs within a machine (physical or virtual) presents its own set of issues.

You could also use the USB autoconnect strings in the vmx of the VM to make it automatically connect the USB WiFi dongle to the VM during powerup, aside from leaving the "Connect at Power On" for the NAT/Bridged NIC unchecked.
https://kb.vmware.com/s/article/1648

0 Kudos
raywood
Enthusiast
Enthusiast

It's a mystery. I've got the latest updates in the VM. But I can't get the WiFi adapters to make any difference. The only way Firefox in the VM can retrieve webpages is when I check the Connected box in Settings.

I know this can work. I had a Win10 guest using one of these same adapters on the Win10 host. The host used one adapter; the VM used the other. Not sure whether the Ubuntu guest is the problem.

0 Kudos
leijonamieli
Enthusiast
Enthusiast

You told earlier that "Guest WiFi adapter: Player > Removable Devices shows a checkmark next to the WiFi adapter". Was this actually the Network Adapter with NAT/Bridge options?

For using the USB Wifi Dongle on the guest, it should show up as a separate removable device.

I created a VM for a quick test and started Ubuntu 18.04 Live. Plugged a mobile network device into a USB port and Removable Devices menu shows

 

guestwifi.png

 

without any special settings needed. Tried 20.04 and worked as well.

Is your USB WiFi dongle showing up as an additional removal device? Sometimes the problem could be different USB versions. Try changing the VM's USB Controller --> USB Compatibility.

---
I don't know about using Microsoft Windows. At least not going online... 🙂

0 Kudos
raywood
Enthusiast
Enthusiast

Mine (Windows host) looks a little different:

Browser.png

In this image, the TP-Link adapter is connected.

If I choose Manage (or Ctrl-D) instead of Removable Devices, I get an option to go into Settings. There, I can choose NAT, Bridged, or other options. Those are independent of whether I connect TP-Link or any other device in the menu selection shown in this image. I assume those (i.e., NAT, Bridged, etc.) refer to the guest's connection to the host, not to these external USB devices.

So I think we are talking about the same thing. It looks a little different in your Ubuntu example, but close enough.

What I am saying, then, is that I can go online, in the VM, by going into Settings > check the Connect box > choose NAT or Bridged (or possibly one of the other options); but I cannot go online in the VM without checking the Connect box. This is true regardless of whether the TP-Link or Ralink WiFi adapter is connected at the menu pick shown above.

(I assume the Network menu pick highlighted in that image refers to a virtual ethernet connection.)

Unfortunately, in Settings > USB Controller, setting USB Compatibility to USB 2.0 or 3.1 does not seem to make any difference.

0 Kudos
leijonamieli
Enthusiast
Enthusiast

Menu item "Network Adapter" refers to the virtual ethernet connection, right. Now I made a bold move and removed it from the settings altogether.

 

settings.png

 

 

It does not show up in the guest window menu either. The USB Connected device "HMD Global..." still keeps me online.

 

vmmenu.png

 


So, TP-Link is one of your USB Wifi adapters. It is connected to guest. Next (hopefully last) step would be to configure the Wifi connection inside the guest Ubuntu (not the Player settings). If it is password protected with WEP/WPA/WPA2.

 

wifi1.png

wifi2.png

 

I'm running out of ideas. Fingers crossed.

0 Kudos