LesBriggs
Contributor
Contributor

Host printers disappeared after update to Workstation Player 12.5

I am running Win XP Pro guest on a Win 10 Host.  All host printers (and everything else) works fine on version 12.1.1 build-3770994. After upgrade to 12.5.0 all the virtual printers disappeared.  I have tried everything I can think of including removing and reinstalling the software and generating a new virtual machine, but the printers stay gone. When I restore Vmware from a backup to the 12.1.1 version, it works fine again. Am I locked into using v.12.1.1 forever?

7 Replies
dazzweb
Contributor
Contributor

I've experienced the exact same problem!?
I'm running Win XP Pro on a Win 10 Host (Anniversary Update), and after I've updated to the latest 12.5.0 all the virtual printers had disappeared Smiley Sad
On Startup I noticed the error saying that printers needed to be enabled, but even after enabling printers under preferences etc still no printers?

At the moment I've done a temporary workaround by sharing the printer on the win 10 host, then installing a printer within my Xp Pro guest, but I've several printers I need to access and would like it working as it was previously!

LesBriggs
Contributor
Contributor

Hi dazzweb, Thanks for the info! I'll install my most used printer per your suggestion of sharing and installing on the guest. I, too would like to see VmWare fix this problem.  There seems to be many other problems with the 12.5 release, so maybe an update might be coming in the not too distant future.

kanger
Contributor
Contributor

I have this issue as well.  I have win10 on multiple hosts computers.  They recieved the anniversary update for windows.  Then I updated vmware to 12.5 on all hosts.  Also updated vmware tools.  I have windows xp home and also windows xp pro as guest virtual machines.  After the update I lost all printers.  Local and network printers are gone.

Basically I'm seeing the same issues. 

dazzweb
Contributor
Contributor

Hi LesBriggs, yes hoping for an update very soon, as installing one printer as mentioned was only a temporary fix, as I have a couple of printers installed, but also adobe printer, which without installing the full software (that I don't want to do) I have no workaround, so hoping that I don't need that feature before a fix appears!! Failing that I might have to drop back down a release to keep my system running.

0 Kudos
JShieldz
Contributor
Contributor

I can confirm when using Workstation 12.5+, ThinPrint does NOT work for Windows XP SP3 (guest) on Win 7 Pro x64 (host).    For some reason the ThinPrint services simply don't start.  The services are not even listed in the services list in XP.  I do see ThinPrint mentioned while installing VMware Tools but it basically disappears afterwards.

No problems when using Workstation 12.1,  ThinPrint runs just fine on XP guest.

Hope the dev team can fix this soon.

0 Kudos
dazzweb
Contributor
Contributor

Can anyone confirm if the above issue has been resolved?
I spent many hours lost trying to resolve, but in the end resorted to dropping back to version 12.1.1 several times and for the past 6 months have stayed on 12.1.1 as I'm VERY hesitant to update incase I lose the printing function again which is crucial!
The latest 12.5.6 has just been prompted for me to download, but again reluctant to install as I don't want to have to find I have to drop back to 12.1.1 Smiley Sad

0 Kudos
dazzweb
Contributor
Contributor

For those who had the printer problem, after missing several updates, Yesterday (04-10-2017) I finally made the Plunge and updated from Version 12.1.1 to 12.5.7..

I can confirm that I still have printer capability Smiley Happy as I did have previously with 12.1.1 that I've been stuck with for quite a while!!

As I got nowhere trying with versions 12.5.0 & 12.5.1.....

So I'm guessing somewhere along the line the problem we were having has been resolved.... :smileycool: