Highlighted
Contributor
Contributor

Headless VMware Player usage with vmrun?

Jump to solution

After installing both VMware Player 3.1.0 and VIX 1.9.0 on a Linux (Ubuntu 10.4) host, I'm attempting to start a virtual machine that can continue to run even when the console application isn't visible (headless mode), sort of like how VMware Server does things.

I'm able to do the following:

vmrun -T player start ~/vmware/server1/server1.vmx nogui

This does exactly what I want, but as soon as I invoke "vmplayer" in order to access the console, I can't quit the vmplayer process without my virtual machine being either powered off or suspended--I'd like it to keep running.

I want a way to either:

  1. run a console type application (a la vmware-server-console in VMware Server v1) to connect to the vmx process running my virtual machine; or,

  2. specify that when I "quit" vmplayer, the running virtual machine is to keep on running (as though you could specify something like pref.vmplayer.exit.vmAction = "detach") in the preferences file.

Any ideas?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Immortal
Immortal

Actually, oops, I assumed too much. You can try setting the following in your preferences file:

pref.vmplayer.exit.vmAction = "disconnect"

which should have the same effect. I thought that was represented in the UI but I was mistaken.

I hope this helps!

Carmen

View solution in original post

0 Kudos
9 Replies
Highlighted
User Moderator
User Moderator

Hi,

Well being rude to your vmplayer GUI process seems to do it.

Try:

killall -9 vmplayer

Down here it kills the GUI and leaves the vmware-vmx process running.

So if you restart the player afterwards and then "start" the VM again it will reattach the GUI to the running process.

Try it, works with no issues down here.



--
Wil
_____________________________________________________
VI-Toolkit & scripts wiki at http://www.vi-toolkit.com

Contributing author at blog www.planetvm.net

Twitter: @wilva

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Immortal
Immortal

Interesting ... On Windows I do the same - just kill vmplayer




___________________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Highlighted
User Moderator
User Moderator

Hi Ulli,

Yes it works. Too bad that you will end up clicking the X-button out of habit and hereby killing/closing your VM without wanting to do so.

Habits are a difficult thing to change.



--
Wil
_____________________________________________________
VI-Toolkit & scripts wiki at http://www.vi-toolkit.com

Contributing author at blog www.planetvm.net

Twitter: @wilva

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Immortal
Immortal

If you go to your "File > Player Preferences" menu, you should have an option under "Close Behavior" for this - "Leave the virtual machine running". If that is selected, when you close Player your VM should continue to run headless in the background.

Unfortunately, for now this is a player-wide setting, so it will affect all VMs that you run in Player. For VMs that you don't want to leave in headless mode, you would have to shut down manually by going to the VM > Power menu and selecting Suspend or Power Off before exiting Player.

carmen

0 Kudos
Highlighted
Contributor
Contributor

If you go to your "File > Player Preferences" menu, you should have an option under "Close Behavior" for this - "Leave the virtual machine running". If that is selected, when you close Player your VM should continue to run headless in the background.

Unfortunately, for now this is a player-wide setting, so it will affect all VMs that you run in Player. For VMs that you don't want to leave in headless mode, you would have to shut down manually by going to the VM > Power menu and selecting Suspend or Power Off before exiting Player.

carmen

Unfortunately my player does not have an option to "Leave the virtual machine running". But that's exactly the kind of option I'm looking for. Does your player instance show such an option? What version are you running?

0 Kudos
Highlighted
Immortal
Immortal

Actually, oops, I assumed too much. You can try setting the following in your preferences file:

pref.vmplayer.exit.vmAction = "disconnect"

which should have the same effect. I thought that was represented in the UI but I was mistaken.

I hope this helps!

Carmen

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

Actually, oops, I assumed too much. You can try setting the following in your preferences file:

pref.vmplayer.exit.vmAction = "disconnect"

which should have the same effect. I thought that was represented in the UI but I was mistaken.

I hope this helps!

Carmen

That did it!

How did you find out about that option? I'm suspecting that VMware Player is more capable than what it lets on... wish the UI wasn't so dumbed down.

thanks again!

0 Kudos
Highlighted
Immortal
Immortal

I'm a Player developer!

The party line is that if you want the features, consider Workstation. But the two products do share a lot of functionality, so you're not far off the mark.

I'm glad to help!

0 Kudos
Highlighted
Contributor
Contributor

Has this changed in any way recently? I get a unrecoverable error: NOT_IMPLEMENTED with a reference to d:/build/ob/bora-324285/bora/apps/vmplayer/win32/playerApp.cpp:2363. It also generates a .log and a .dmp file. I can post these if it helps.

It does however seem to do what it's told because when I start up the machine again it's in the same state instantly. Now if I only could get rid of the error dialog and unneccessary logfiles, I'd be happy. Smiley Happy

0 Kudos