Emmerich
Contributor
Contributor

Guest can't see USB hard drive or NAS

My host is Win7, guest is XP. Install went fine. Internet works fine.  Can't get XP to see a USB hard disk and also can't see a NAS on my home network. Well, it can't see the home network at all.  None of the help files are useful, no options are available to connect a USB device.  Can anyone point me in the right direction?

thanks

Fred Emmerich

0 Kudos
13 Replies
Emmerich
Contributor
Contributor

Update:  I can see the USB drive, no luck with the NAS or seeing anything on my home network.  The USB required unplugging it and plugging back in, kinda simple if not documented....  wish there was a more thorough docs on how to set the network settings.

0 Kudos
Shootist
Enthusiast
Enthusiast

Well what is your network setup now?

Do have it set to NAT or Bridge?

In Bridge the VM is just another part of your LAN with a IP in the same range as your LAN. Mot then likely 192.168.x.x

In NAT it become a separate network and will have a different IP in a different range then your LAN using Network Address Translation between the 2.

0 Kudos
Emmerich
Contributor
Contributor

I have tried it both ways with no luck.  I understand the differences in each setup, I am not sure which is better in different circumstances. The help describes each, but not one which should be used.

thanks

Fred Emmerich

0 Kudos
Shootist
Enthusiast
Enthusiast

I've been hunting around for a clue to your problem but then noticed I had something amiss myself. I couldn't connect to USB devices connected to the Host.

Turns out I had a service set to manual on the host PC that stopped the VM from connecting (they call it Arbitration Service) to the host USB devices.

So check to see if any of the VMware service have been set to Manual or Disabled.

If the NAS is set to be shared on your LAN it should show up on every PC connect to the LAN. Especially if you can see all other PCs, printers and the like from the VM.

Can you PING it by IP?

0 Kudos
srnhpp
Enthusiast
Enthusiast

                               

Make sure that your USB driver added in your windows xp OS if not please add USB driver in your windows xp.

0 Kudos
Shootist
Enthusiast
Enthusiast

Emmerich wrote:

I have tried it both ways with no luck.  I understand the differences in each setup, I am not sure which is better in different circumstances. The help describes each, but not one which should be used.

thanks

Fred Emmerich

Neither network setting is better then the other. Depending on what you want.

If you want the VM and other computers on your LAN to share files more easily then Bridge is the correct setting.

If you want the VM to be separated from your LAN then NAT is the better choice.

I personally go for Bridge as I want the VM to see all other PCs on the LAN and I want all other PCs to see the VM as just another PC on the network, including the Host PC.

0 Kudos
Shootist
Enthusiast
Enthusiast

srnhpp wrote:

                               

Make sure that your USB driver added in your windows xp OS if not please add USB driver in your windows xp.

USB drives are included with all versions of XP and install when you install the OS. No need to add them, they are already there.

0 Kudos
WoodyZ
Immortal
Immortal

Shootist wrote: USB drives are included with all versions of XP and install when you install the OS. No need to add them, they are already there.

The term USB is generic since there several versions and blanket statements are often erroneous and one should probably refrain from such statement unless one knows exactly what one is talking about or explicitly and specifically qualifies the statement.  Your statement is not totally true as the original GA release of Windows XP did not ship with USB 2.0 drivers and were not included until Service Pack 1.

From a Microsoft KB: 329632

USB 2.0 is a specification revision of the original USB 1.1 specification. USB 2.0 was approved April 2000. The corresponding EHCI specification was finished March 2002.

Windows XP did not include support for USB 2.0 technology for the following reasons:

  • There were no production quality EHCI 1.0 compatible host                     controllers.
  • There were not enough production-quality USB 2.0 devices                     for testing.

The Windows XP Service Pack 1 installer is designed to update all drivers and all files that are included with Windows XP. Because USB 2.0 drivers are not included with Windows XP, you must follow the steps in this article to obtain the latest drivers after you install Windows XP Service Pack 1.

0 Kudos
Shootist
Enthusiast
Enthusiast

Yes that is true but all versions of Windows included USB drives from Win 98SE on. Even if they are only USB 1.1 drivers and you have USB 2 ports they will still be seen and usable, only at the lower/slower speed.

Thanks for the info though.

0 Kudos
Emmerich
Contributor
Contributor

I have the USB working, now just trying to get the networking to come together.  I had to unplug the USB drive and plug it back in when the VM was active.

I will try to se the networking to bridge.  I see it is set in VM but also there is a setting in the host where you see the VM network adapters, do I need to worry about that?

thanks

Fred Emmerich

0 Kudos
Shootist
Enthusiast
Enthusiast

While you're in the setting go to the options tab and under Shared Folders tick "Always enabled" and see if that helps.

Also look in Network connection sharing center and see if you have 2 VMware Net adapters listed in the "Public Network".

For some reason on my Win 7 PC VMware had installed 2 adapter in the Piblic Network area making browsing my Lan very slow. They had IPs in 2 different ranges outside my LAN IP range. One was 192.168.158.x and the other was 192.168.253.x. My LAN is 192.168.1.x. I think this was caused by the Shared Folder setting of Disabled, but I'm not sure.

You can either disable them in the Net Sharing Center or go into Device Manager and under Network Adapters and delete them. I first Disabled them then I deleted them. I trust my Virtual Machines.

0 Kudos
Emmerich
Contributor
Contributor

I am not sure where to look for the "always enabled" setting...

The 2 VMWare adapters are not listed as public.

0 Kudos
Shootist
Enthusiast
Enthusiast

Open Player, click on the VM so it is highlighted (in my case that is Windows XP Professional) open "Edit Virtual Machine Settings" Click on the "Options Tab" at the top left hand side of the dialog windows that opens.

0 Kudos