VMware Communities
nmavra
Contributor
Contributor

Guest can't connect to internet in bridged mode

Hello all,

I have been using VMWare Player at home in order to create a win2003 machine to run a collaboration website (FengOffice, former Open Goo).

I have setup the guest fine, and everything is working as planned. Now I uploaded my virtual machine to my dedicated server but now I can't seem to have internet access if I used bridged mode.

My dedicated server provider has provided me with 2 IPs. I use the first IP for the host, and the second for the guest.

Network settings seem to be fine, they are the same between the 2 machines apart from the IP of course. This should be a rather straightforward network.

The host and guest can ping each other successfully, however the guest will not access the internet. I have tried disabling windows firewall in both machines, but still no joy. Can someone shed some light in this? I have been trying to make it work for days and each time it seems that it won't work on any of my 2 dedicated servers, so I have used 2 different pools of IPs. The same VM works fine on my 3 home machines.

Thanks for your help and time!

Reply
0 Kudos
8 Replies
WoodyZ
Immortal
Immortal

Wile on the dedicated server as a test, in the Windows VM, if you configure the NIC to use DHCP and in the Settings for the VM you set the Network Adapter to use NAT can the VM now connect to the Internet, like google.com?

Reply
0 Kudos
nmavra
Contributor
Contributor

Hello WoodyZ,

Yes NAT mode works ok!

Its bridged that troubles me!

Reply
0 Kudos
WoodyZ
Immortal
Immortal

Set it back to Bridged and make sue you configure the NIC properly and then use the Virtual Network Editor and if "Bridged to:" is set to "Automatic" then change it to the specific Network Adapter.

Note: The Virtual Network Editor is vmnetcfg.exe and may not have been installed in your VMware Player install. You can execute VMware-player-<xxxx-xxxx>.exe with the --help argument to get syntax to extract the contents and then extract the contents and then in the network.cab extract the vmnetcfg.exe to the C:\Program Files\VMware/VMware Player folder.

Note: (<xxxx-xxxx> is a series of numbers representing the version and build numbers.)

Reply
0 Kudos
nmavra
Contributor
Contributor

ok I extracted the file vmnetcfg.exe but when I run it I see various virtual interfaces, whereas I only have 2. I have changed AUTO to reflect my host interface, but I did that at VMNet0 which I don't see in my host OS network interfaces. Have a look at the screenshot below:

So whats the next step? Do I create VMNet0, and if yes, how?

Reply
0 Kudos
WoodyZ
Immortal
Immortal

You will not see VMnet0 in the Network Connection on the Host as it only shows as a check box named VMware Bridged Protocol on the General tab of the Local Area Connection Properties dialog box.

So I'm assuming that you still don't have Internet Connectivity in the VM even though you've bridged directly to the target Network Adapter so without seeing the output of ipconfig/all on both the Host and the Guest so I can see if you have any obvious errors however you may not want to post the output here.

Have you verified that the IP Address, Subnet Mask and DNS Server information you're using in the VM works on a Physical Machine and or have you tried using the IP Address, Subnet Mask and DNS Server information from the Host, which is working, and tried it in the Guest either by swapping the information or just using the Host's IP info in the Guest and have the Host just use a 169.254.x.x IP Address but having VMware Bridged Protocol checked on the adapter so it can use that adapter for the Guest?

You could try removing the Network Adapter for the Guest OS and from the VM's Settings reboot and then add back to see if that changes anything although since it's working in NAT mode I doubt it will have any effect and am just mentioning it because stranger things can happen if you know what I mean. Smiley Happy

Reply
0 Kudos
nmavra
Contributor
Contributor

I forgot to paste the ipconfig /all from the guest and host, please have a look. I think the setup is correct. I had to remove parts of the actual IP addresses, but if you think you need it all I can surely send them to you by email or PM.

Guest

Windows IP Configuration

Host Name . . . . . . . . . . . . : 2003VM

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter 77.68.38.15:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection

Physical Address. . . . . . . . . : 00-0C-29-6F-8D-B6

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : xxx.xxx.xxx.15

Subnet Mask . . . . . . . . . . . : 255.255.252.0

Default Gateway . . . . . . . . . : xxx.xxx.xxx.1

DNS Servers . . . . . . . . . . . : 213.171.192.249

213.171.193.245

C:\Documents and Settings\Administrator>ping xxx.xxx.xxx.14

Pinging 7xxx.xxx.xxx.14 with 32 bytes of data:

Reply from xxx.xxx.xxx.14: bytes=32 time=2ms TTL=128

Host OS:

Windows IP Configuration

Host Name . . . . . . . . . . . . : XXXXXXXX

Primary Dns Suffix . . . . . . . : XXXXXXX

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : XXXXXX

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Intel(R) 82567LM-3 Gigabit Network Connec

tion

Physical Address. . . . . . . . . : 00-19-99-63-5A-FB

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : XXX.XXX.XXX.14

Subnet Mask . . . . . . . . . . . : 255.255.252.0

Default Gateway . . . . . . . . . :XXX.XXX.XXX.1

DNS Servers . . . . . . . . . . . : 213.171.192.249

213.171.193.245

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1

Physical Address. . . . . . . . . : 00-50-56-C0-00-01

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.81.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8

Physical Address. . . . . . . . . : 00-50-56-C0-00-08

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 192.168.0.1

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . :

The IP that I gave the guest works fine if I add it to the host, and by adding I don't mean changing, but actually adding it on the network interface.

I can't assign the xxx.xxx.xxx.14 IP to the guest because this is the IP of the dedicated server and many services will not work.

Reply
0 Kudos
dkraut
Enthusiast
Enthusiast

I had a similar issue with workstation. I finally solved it by editing settings on the virtual machine and removing the Network Adapter. Once it was removed, I added it back and voilà! network worked fine after I powered it up. Give it a try...

Reply
0 Kudos
nmavra
Contributor
Contributor

Thank you for your answers, apparently my dedicated server company had enabled MAC Address filtering on its switches.

Once I informed them of the VMWare issue they included my VM mac address in the whitelist and everything is working fine!

On another note, removing and re-attaching the network interface worked today on my VMWare machine that runs on my laptop! So thanks again for your suggestions!

Reply
0 Kudos