VMware Communities
thirdnormal
Contributor
Contributor

Guest Machines Do Not Show in VMPlayer Library

My vmware player does not show gest machines in the library. My troubleshooting suggests its a permissions error on whereever the library data is stored.

When I try to open a guest machine  the player does not show the  guest in the inventory pane of the  player. However I can run  vmplayer /path/to/machine.vmx and the machine  will open execute  properly.

When  I run vmware player as root (or even a regular user) it works   correctly - so it seems clearly tied to my user account. I have tried rm  -rf ~/.vmware and rerunning the player but I  get the same behavior.

The problem happens with all guest machines - so it does not appear to be related to anything about a machine itself.

Does anyone know where vmware player stores the inventory data? Nothing in the  ~/.vmware directory seems to be related to this, but the library data must be persisted somewhere. Where is this file?

I'm running vmware player 3.1.3 build-324285 on Ubuntu Linux  2.6.31-22-generic-pae Ubuntu 9.10.

Thanks for any help.
21 Replies
continuum
Immortal
Immortal

favorites.vmls

has entries like

vmlist3.config = "moa.vmx"


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
WoodyZ
Immortal
Immortal

favorites.vmls

Ulli, what are you thoughts on these observations?

As far as I can tell by running utilities that monitor filesyststem activity the favorites.vmls is only used by VMware Workstation not VMware Player 3.x which is what the OP is using.  Also on both Windows and Linux Host's that only have VMware Player 3.x installed the favorites.vmls does not even exist, at least on several different Hosts, both Windows and Linux, that I have that only have VMware Player is installed.  Additionally the VM's that show in the VMware Player UI are only listed in the preferences.ini on a Windows Host and not in the favorites.vmls where VMware Workstation is also installed.

Interesting enough on a Linux Host with only VMware Player 3.x installed I actually could not ascertain what file if any the VM entries on the VMware Player UI was saving the information to until I actually changed the order in the list via drag and drop, which you cannot do in Windows, and then it would write entries to the ~/.vmware/preferences file.  On a Linux Host it is almost like VMware Player enumerates the contents of ~/vmware and creates the list in memory only until the order in the list was changed.  This behavior does not appear to be the same on a Windows Host with VMware Player only as it was clearly writing to the preferences.ini.

Anyway these were some of my observations when trying to help the OP a week a go in a duplicate post.

Reply
0 Kudos
continuum
Immortal
Immortal

Woody - on some vmplayer-installations you also see a "featured-VMs" file - not sure about the right name right now

actually I do not really know wether VPlayer 3 on windows only reads preferences.ini or all 3 of these files
it may also use HKEY_CURRENT_USER\Software\VMware, Inc.


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
DanielRigal
Contributor
Contributor

Hi everybody. This is my first post here.

I have been having the same problems as the OP here. I am using Xubuntu 12.04 and VMWare Player 4.04, both 64 bit.

I do not have a solution but I have discovered something very odd that nobody else has mentioned and which might help somebody more knowledgable than me to figure out a solution.

The key to the problem seems to be the file:

  • ~/.recently-used.xbel

When I add new VMs to the library I can see them getting stored in this file.

When I log out and back in again the file is gone.

When I add new VMs to the library again the file is recreated and lasts until the next logout and login.

If I backup the file while it has VMs in it and then restore it manually after it gets deleted then the VMs reappear in the library, until the file gets deleted again.

Conclusion: Something, I have no idea what, is trashing the file ~/.recently-used.xbel on logout or login and this is why the library is lost after reboots.

Irony: Googling "recently-used.xbel" reveals that this file is not unique to VMWare but is used by other applications (although they keep theirs in ~/.local/share/recently-used.xbel) and most people asking about it are trying to get rid of it not retain it.

Is that any help? Does that give anybody a clue they can pick up and run with? It would be nice to get it fixed.

PS: I just went looking in /etc to see if anything there was trashing it. I didn't see anything but I did notice that Apparmor has rules relating to it. I don't know if that is any help?

Reply
0 Kudos
PsychoDoc
Contributor
Contributor

Hello everybody,


I am not an native speaker, so please be lenient.
I am running two computers with ubuntu 12.04 an Vmware Player 4.04, 64bit. On one of the computers the mentioned problem occurs, on the other not. Both have the file

/home/user/.local/share/recently-used.xbel

It contains a line that points to the VM, here Windows XP:

<bookmark href="file:///home/user/.vmware/Windows XP/Windows XP.vmx" added="2012-07-03T16:35:57Z" modified="2012-07-03T16:35:57Z" visited="2012-07-03T16:35:57Z">

The other computer (the one, that does NOT save the library) creates an addtional file

/home/user/.recently-usted.xbel

containing the same line. This file disappeares after logout.

The question is, how do we bring VmPlayer to use the file /home/.local/share/recently-used.xbel to store the library and not to create /home/.recently-usted.xbel?

Reply
0 Kudos
DanielRigal
Contributor
Contributor

Yes. I think you are right.

I looked in /home/user/.local/share/recently-used.xbel and I found it had saved my list of VMs from the first time I used VMWare Player however it now takes no notice of that file and insists on using /home/user/.recently-used.xbel which gets wiped each time.

I found that somebody already filed this as a bug report with Ubuntu but it was rejected:

https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1007336

Their logic for rejecting it is that /home/user/.local/share/recently-used.xbel is the correct location and that is not getting wiped. This makes sense but they do not explain what is wiping /home/user/.recently-used.xbel or why, so it doesn't help us. I think it probably is a bug in VMWare Player that it uses the wrong location but, again, that doesn't help us unless there is some way to force it to use the correct location. I tried symlinking it but the symlink just gets deleted.

The person who filed the report does not think it is Apparmor's that is wiping the file after testing that taking references to the file out of Apparmor's config does not fix it. This makes sense. Apparmor is supposed to deny access to files, not actually delete them.

I guess this will probably be fixed when a version is released which officially supports Ubuntu 12.04 as a host. Lets hope so anyway.

DanielRigal
Contributor
Contributor

I have upgraded to VMWare Player 5.0 (64 bit) and the problem is still present (on Xubuntu 12.04, fully patched, 64 bit).

I do not know if VMWare Player 5.0 officially supports Ubuntu 12.04. Supported Linux versions are not mentioned in the Release Note. All I know is that it supports Windows 8, like I care. 😉

Does anybody have any suggestions?

Reply
0 Kudos
dlang123
Contributor
Contributor

I also have this problem in Ubuntu 12.10 with VMWARE Player 5.0.1 build-894247

Reply
0 Kudos
wyaeld
Contributor
Contributor

Still not fixed with Ubuntu 13.04 and VMWARE Player 5.0.2 build-1031769

Reply
0 Kudos
mprocopio
Contributor
Contributor

An easy enough workaround.

Just create a symbolic link:

ln -s /home/user/.local/share/recently-used.xbel /home/user/.recently-used.xbel

That seemed to fix the problem for me.  Thanks for the previous posters who noticed which files were being used!

Reply
0 Kudos
jpassos
Contributor
Contributor

Hi

I have a home laboratory for studies on virus behavior in versions of 32 and 64-bit windows .
In this particular case I run these virus from my collection always in different versions to

track their behavior whenever change the operating characteristics of the system host, to which the virus runs.

I had the same problem and solved in a way not very different from that in the favorite vmware -player panel.

In my area of work I created a folder ( vm- links) where I put all links to major versions of windows that run more .

The command prompt shortcut was as follows:
    /usr/bin/vmplayer  /path/to/file/with/extension/vmx

This resolve to much in the execution of the virtual machine, faster.
I really hope this will help you or provide an alternative idea to your problem.


Bye and virtual good playing ...

Reply
0 Kudos
dsy72
Contributor
Contributor

This behavior still exists in Ubuntu 14.04 LTS and VMware Player 7.1.2. The file /home/user/.local/share/recently-used.xbel will be emptied from time to time and every time you log out, thus the library / list of VMs will be lost.

This only happens if you have deactivated 'Record file & application usage' in Ubuntu System Settings 'All Settings / Security & Privacy / Files & Applications'.

If you activate 'Record file & application usage' your list of VMs will not be lost anymore, as the file 'recently-used.xbel' will no longer be emptied. I'm actually very happy to have discovered this, because before I had to manually restore the list of VMs dozens of time.

Reply
0 Kudos
TomReed
Contributor
Contributor

Same problem here with Ubuntu 16.04. 'Record file & application usage' is on. This is on 2 different machines. Locations added when searching are remembered and the guest vm's are remembered during the session, but are lost when logging out. Tried to create a symbolic link, but received error because the file already existed. It would be nice if this was fixed.

Reply
0 Kudos
jbankstonga
Enthusiast
Enthusiast

I'm running Ubuntu x64 14.04-LTS, VMW wosktation 12.1.1 and problem still here. I created recent-used.xbel.txt and set up a cron job to copy it around as needed every 5 minutes. Crappy way to do it, but it works for now.

-Jeff

Reply
0 Kudos
Marianus
Contributor
Contributor

Hey guys,

I have a stupid solution for the issue but hey at least it works.

On my machine I'm running ElementaryOS Loki and Workstation 12.5

Elementary OS 0.4 I believe is based on Ubuntu 16.04; both use same kernel

@Mi-Book:~$ lsb_release -a

No LSB modules are available.

Distributor ID:    elementary

Description:    elementary OS 0.4 Loki

Release:    0.4

Codename:    loki

mi@Mi-Book:~$ uname -a

Linux Mi-Book 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I had the same issue as the OP.

Resolved the issue by running:

1. mi@Mi-Book:~$ sudo vmware

2. Create a VM folder

3. Open the lost VM and drag it into the folder.

4. Close Workstation and reopen from Application Launcher

VM Folder and VM stayed in Workstation.

Hope this helps someone

Axentar
Contributor
Contributor

Thx man, that's working!

Reply
0 Kudos
jimbean123
Contributor
Contributor

ubuntu 16.04 vmplayer 12.5.2 worked on initial install worked for about a week then when upgraded to 12.5.4 it dosen`t save my vm files library any more

im running about 6 different vm systems  on 2 different pc`s and 2 different operating systems and im no expert so dont ask me, just a enthusiast

Reply
0 Kudos
sdaks
Contributor
Contributor

Have had this issue for a while and did some more searching today and came across this thread from 2015 which suggested it's a security/privacy setting related issue.   I saw a post from user dsy72 stating:

The file /home/user/.local/share/recently-used.xbel will be emptied from time to time and every time you log out, thus the library / list of VMs will be lost.

This only happens if you have deactivated 'Record file & application usage' in Ubuntu System Settings 'All Settings / Security & Privacy / Files & Applications'.

If you activate 'Record file & application usage' your list of VMs will not be lost anymore, as the file 'recently-used.xbel' will no longer be emptied. I'm actually very happy to have discovered this, because before I had to manually restore the list of VMs dozens of time.

While I don't use Ubuntu, in Linux Mint (latest release 18.3) I went into privacy settings and told it to remember recently accessed files (Set to "on") and Never forget old files (Set to "On") and now I can add the machine(s) to my Library.

Hope this helps others!

Bucky2090
Contributor
Contributor

This worked for me. Ubuntu 16.04. VMWare Workstation 14 Player - 14.1.2 build-8497320.

Thanks a lot.

Reply
0 Kudos