nitrobay
Contributor
Contributor

Change resolution of framebuffer/TTY

Hello,

I use arch linux. I use vmware workstation player 15. I installed the vmware tools. In a desktop environement resizing works however in the default terminal before opening desktop (tty for example) the window is too small,

Whether in vmware's display options I set a fixed resolution (like 3000X2000) or I choose to have same resolutions in my guest than my host (windows 10, I have a 3000x2000) doesn't change anything the resolution reported by hwinfo --framebuffer are between 400x300 and 1152x864 none of them being big enough. I follow the guide https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks set the framebuffer resolution and so i change the GRUB's config file GRUB_GFXMODE to the max resolution I of the hwinfo --framebuffer list I do the reload of the config with grub-mkconfig and reboot but still the framebuffer's size is never changin.

So my tty terminal is like 1/30 of my screen (incredibly annoying on a 3000x2000 13 inches screen) even tho once again resizing a desktop env when I launch XORG works.

0 Kudos
2 Replies
La_Poutine_
Contributor
Contributor

I had the same issue, and right now I set the HW compatibility settings of the VM to 10 as a workaround.  Anything higher seems to cause the issue mentioned above.

Anyone who can reply to this thread with a permanent solution while using a compatibility setting of 11 and higher would be greatly appreciated.  Smiley Happy

Thx !

0 Kudos
spuch
Contributor
Contributor

For me the same.

I'm using linux in a VM on ESXi 6.5. When opening the VM through the Web Host client using Remote console an instance of VMWare Workstation 16 Player is started. While I can set any appropriate resolution for the X-server the console seems to be limited to 1152x864 like already pointed out in the first posting. To avoid flickering during boot a I set "vmwgfx.enable_fbdev=1 vga=834" as parameter to the linux kernel in grub2 which enables framebuffer support as fast as possible (by loading kernel module vmwgfx) and selecting the highest resolution 1152x864 (834 is 0x0342). Setting this resolution to the x-server as well does at least avoid the window to resize every time when switching between X environment and console (tty) using STRG+ALT+F2 etc.

However, it would be nice to set a greater resolution as many screens support at least Full HD (1920x1080) or above, so any solution would be welcome...

The workaround for higher resolutions by setting the hardware version of the vm to "10" works of cause as documented here in the forum in this thread

0 Kudos