ECvoyager
Contributor
Contributor

Cannot connect to internet with Windows 7 on VMware player

I created a Windows 7 VM on VMware player on my Windows 7 PC. The VM can connect to my home network. But it cannot connect to the internet.

I have tried to disable Microsoft firewall. But it only works for that VM session. Once I restart the VM a few days later, the VM always lost the internet connection. Hoe network is always accessible though.

The network of my VM is in bridge mode.

Anyone has a tip to solve this?

0 Kudos
7 Replies
YLeduc1234
Enthusiast
Enthusiast

Hello,

open a command prompt and try the following commands:

ping www.cisco.com

ping 69.192.16.170

ping 209.217.237.157

ping www.bell.com

and tell me if you have any replies and from which ones. If you get results from ping with specific IP address and not from names, you must look into a dns issue.

Let me know

gszoniec
Enthusiast
Enthusiast

Change to NAT in connection settings. In most cases it works

for me, when other types of connection need more "waving hands".

ECvoyager
Contributor
Contributor

Here is the responses from theWindows 7's cmd window:

----------------------------------------------------------------------------------------

C:\Users\Eric>ping yahoo.com

Pinging yahoo.com [98.137.149.56] with 32 bytes of data:
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.

Ping statistics for 98.137.149.56:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

C:\Users\Eric>ping 98.137.149.56

Pinging 98.137.149.56 with 32 bytes of data:
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.
Reply from 192.168.1.30: Destination host unreachable.

Ping statistics for 98.137.149.56:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

----------------------------------------------------------------------------------------

I noticed that the response came from 192.168.1.30 which is the VM's own ip address (via DHCP). It seems like the VM is behaving like its own router. Should I disable it? How?

Thanks

Eric

0 Kudos
ProPenguin
Hot Shot
Hot Shot

Check your default gateway and make sure it is correct.

0 Kudos
ProPenguin
Hot Shot
Hot Shot

Any Luck?

0 Kudos
ECvoyager
Contributor
Contributor

Default gateway looks all right.

Spent a few hours last night with the Windows 7 VMs. I think the problem is not from ip configuration. (My ip configuration is very simple, just DHCP.) It's probably from Microsoft's HomeGroup/WorkGroup/Public groups.For some reasons, Windows 7 thinks I have multiple "groups" in my home. In Control Panel -> Network, it shows two groups in my net: one of Homegroup which is connected. The other "Public" which has a big "X" on top of it. I'm still searching for a way to ask Windows 7 to remvoe all "groups" and re-discover the network. No luck yet.

0 Kudos
ECvoyager
Contributor
Contributor

Changed my home network from MS Homegroup to Work Group and everything is fine.

Thanks for all the helps.

0 Kudos