mikecrowe3030
Contributor
Contributor

Can't start VM. Getting: Could not create anonymous paging file

I suddenly can't start my virtual machine. Getting this error:

Jul 30 22:25:48.177: vmx| Log for VMware Player pid=9004 version=2.5.2 build=build-156735 option=Release

Jul 30 22:25:48.177: vmx| Host codepage=windows-1252 encoding=windows-1252

Jul 30 22:25:49.121: vmx| Msg_Post: Error

Jul 30 22:25:49.121: vmx| http://msg.mainMemWin32.createFileAnon Could not create anonymous paging file for 1024 MB: The paging file is too small for this operation to complete.

Jul 30 22:25:49.121: vmx| http://msg.mainMem.pagefileAllocFailed Failed to allocate main memory.

Jul 30 22:25:49.121: vmx| http://msg.moduletable.powerOnFailed Module MainMem power on failed.

I've tried removing files except vmdx and vmx, but same error occurs. Anybody know what I'm facing?

Tags (2)
0 Kudos
7 Replies
prakashraj
Expert
Expert

Hi,

Check the free space on c drive and free memory availability(RAM) on host machine before start the VM

Prakash

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!
0 Kudos
v22osprey
Contributor
Contributor

Did you ever get a resolution for this issue? I'm having a similar problem with Vmware 2.0. Thanks.

0 Kudos
continuum
Immortal
Immortal

most probable reason: misconfigured Windows so that it does not use a pagefile




_________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
v22osprey
Contributor
Contributor

No, I have a paging file configured for this server min 2gb and max 4gb.

0 Kudos
continuum
Immortal
Immortal

ok - please post the vmware.log then




_________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
v22osprey
Contributor
Contributor

Thanks for responding. I fixed the problem by performing a disk defrag. Seems that vmware likes to have a contiguous paging file.

0 Kudos
cbiero
Enthusiast
Enthusiast

Go the same issue with one VM (upgraded to Workstation 9). The pagefile is the place to look !

I have 4.5Gb of SWAP separated on 2 pagefiles :

- 512MB on the system disk

- 4GB on another physical disk (not system)

For an unknown reason, in the advanced Virtual Memory settings of the host, the currently allocated paging was.... 512MB.

The 4GB files didn't even exists !

The after a reboot of the host, everything came back to normal.

In conclusion : CHECK for the *current* paging file size allocation size on host !

----- If you found this or any other answer useful please use of the Helpful or Correct buttons to help next readers to quickly find the solution. Thanks !
0 Kudos