aalborz02
Contributor
Contributor

CPU has been disabled by the guest operating system error

Jump to solution

Running VMPlayer version 3.1.3 build-324285 on Windows 7 Enterprise 64bit with 8G memory.

When I try to install certain Linux-based VMs from ISOs, within few seconds, I get the error:

"The CPU has been disabled by the guest operating system. You need to power off or reset the virtual machine at this point."

(Also see screenshot attached)

This doesn't happen on other Linux/Windows-based ISOs though. I've Googled the web & VMTN, but haven't found a relevant

answer to my issue.

Thanks in advance

Alex

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Samquejo
Commander
Commander

Hi

Which OS are you tryining to install?

Take a minute to look in VMware Compatibility Guide: Guest/Host Search, and try to upgrade to at least 3.1.4 if your system does not support 64 bits direct execution.

Regards

Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards

View solution in original post

0 Kudos
8 Replies
WoodyZ
Immortal
Immortal

Did you validate the MD5/SHA1 checksum of the ISO Image you downloaded before starting the install?  Also DO NOT use Easy Install and instead select "I will install the operating system later."! Smiley Wink

BTW If you want to attach screen shot you should do it as a graphic image file not as a word processing document! Smiley Wink

0 Kudos
a_p_
Leadership
Leadership

I agree with WoodyZ, check the installation (Linux) image. You may also want to read VMware KB: Understanding the message: The CPU has been disabled by the guest operating system for details about this message.

André

0 Kudos
aalborz02
Contributor
Contributor

Yes I validated the ISO image. As I mentioned, the issue is not specific to this particular ISO. So how not installing OS initially solves the issue??! All I have is a blank VMDK file.

Whenever I try to install OS, I'd run into the same issue.

Btw it's just easier for me to manipulate the image in WORD, which I have always open.

0 Kudos
a_p_
Leadership
Leadership

So how not installing OS initially solves the issue??! All I have is a blank VMDK file.

I think you misunderstood this. What WoodyZ said was just not to use the "Easy Install" feature (i.e. select the ISO in the installation wizard) but select "I will install the operating system later." and after initially creating the VM run the installation with booting off the ISO image. What "Easy Install" does is trying to setup the guest OS with some defaults which - depending on the guest OS (version, kernel, ...) could result in different issues, e.g. the one you see.

André

0 Kudos
aalborz02
Contributor
Contributor

I did, but even after not doing the "Easy Install", I ran the installation & I'm getting the same error!

Btw the VM KB was not much help either.

0 Kudos
a_p_
Leadership
Leadership

To find out what might cause this issue, please provide some detials:

  • what's the reason you are using VMware Player 3.x, doesn't your hardware support a newer version (e.g. no VT-x support)
  • is it possible do download the Linux version you are trying to install, to see whether the issue is reproducible
  • please use the advanced editor and attach the VM's vmware.log file

André

0 Kudos
Samquejo
Commander
Commander

Hi

Which OS are you tryining to install?

Take a minute to look in VMware Compatibility Guide: Guest/Host Search, and try to upgrade to at least 3.1.4 if your system does not support 64 bits direct execution.

Regards

Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards

View solution in original post

0 Kudos
aalborz02
Contributor
Contributor

Upgrading VMplayer did the job. Thanks for your help!

0 Kudos