jmacdonagh
Contributor
Contributor

Bridged networking not working

Jump to solution

Hi, I've installed VMware Player with and created an Ubuntu VM with NAT networking. It worked great, but I needed to have it bridged so I changed the network adapter's type and it worked great. This was when my host machine was connected via Ethernet to my router. Recently, I switched my host machine to use a USB wireless adapter, the Realtek RTL8167 802.11b/g USB 2.0 NIC. Since then, bridged networking no longer works.

I extracted out the VM network configuration tool and ran it. VMNet0 still show as Auto-bridging. Just to be sure, I did Restore Defaults which unintsalled all the VMNets and reinstalled them. Same issue. I also double checked that the Vmware Bridge Protocol was enabled for my wireless network connection on the host.

I ran tcpdump on the Ubuntu VM, and I see some broadcast traffic coming across. I also see my DHCP requests go out, but no responses. Of course my router's DHCP server is set up to give out IPs to anyone. It's almost as if my host, Windows 7 SP1, is not fowarding on the traffic.

Host: Windows 7 SP1 x64

Guest: Ubuntu 10.10

VMware Player 3.1.3-324285

Any ideas? Thanks!

0 Kudos
1 Solution

Accepted Solutions
WoodyZ
Immortal
Immortal

Turn off Automatic Bridging and set VMnet0 to the specific NIC as this feature can be buggy if the Host is multihomed. ( Having more then one NIC).

That said, it may not help if your Router does not support or is not configured for providing more then one IP Address to the same MAC Address with WiFi, which is not uncommon with Managed Routers in Commercial Environments and or some SOHO Routers.

Have a look at my reply Re: Windows 7 - Network Bridge mode trouble... for more details about possible Router issue.

View solution in original post

0 Kudos
2 Replies
WoodyZ
Immortal
Immortal

Turn off Automatic Bridging and set VMnet0 to the specific NIC as this feature can be buggy if the Host is multihomed. ( Having more then one NIC).

That said, it may not help if your Router does not support or is not configured for providing more then one IP Address to the same MAC Address with WiFi, which is not uncommon with Managed Routers in Commercial Environments and or some SOHO Routers.

Have a look at my reply Re: Windows 7 - Network Bridge mode trouble... for more details about possible Router issue.

View solution in original post

0 Kudos
jmacdonagh
Contributor
Contributor

It was the second thing you mentioned. My Actiontec router from Verizion FIOS didn't seem to like give out two different DHCP responses for the same wireless connection. I set a static IP and it worked.

A static IP wasn't ideal, so I got a router loaded up with DD-WRT and set it into client bridge mode. Now my host machine is connected via ethernet which is connected via 802.11 to my Actiontec router. Oddly enough, this works great. My VMs now get DHCP responses from my Actiontec router over the same DD-WRT <-> Actiontec wireless connection.

Thanks!

0 Kudos