admin
Immortal
Immortal

Blank Screen on installation

I'm evaulating VMWare player for my company, as we need other OSes

for simple things and setup is giving me a blank window when I run it.

Itegrity check is passed on the file, I've tried downloading it several

time, as well as other versions. Still blank. I'm getting very

frustrated.

21 Replies
a_p_
Leadership
Leadership

Welcome to the Community,

there are some known issues which can prevent VMware Player from installing.

- run the installation from an empty folder (only the installation package should be there)

- make sure your AV does not block js-Code (this is needed to display the installation screen)

- make sure there are no processes running like webcam.exe or fixcamera.exe

- run the installation package from the command line by adding /z "action"="install"

- run the installation using "run as..." Administrator (e.g. in Vista)

André

0 Kudos
admin
Immortal
Immortal

I've tried all of that including killing all processes that involve webcams. Anti-virus is turned off. This is really pissing me off....

0 Kudos
admin
Immortal
Immortal

Anyone?

0 Kudos
ulfsve
Contributor
Contributor

I am receiving the same blank screen on installation. I'm running windows 7 32bit. Is MS preventing competition from installing there programs?

ulf

0 Kudos
continuum
Immortal
Immortal

I am writing a howto - please read

http://faq.sanbarrow.com/index.php?solution_id=1113

carefully.

Don't miss the steps listed as required after a first failed attempt.




_________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
Hiro14
Contributor
Contributor

I have the same problem trying to install VMware Player on a Windows 7 64-bit pc.  I installed the player on another computer(also Windows 7 64-bit) and it worked fine.  The only difference I could see was that SP1 was installed on the first computer that didn't work.  If you have the Service Pack 1 installed on your machine try removing it and installing again.  Also, I know that Internet Explorer 9 beta creates some issues with programs not working.  Remove that also if you have it.  I hope this works for you. 

I will try to remove these things from the first computer.  Ill let you know if it works or not.

0 Kudos
solbirn
Contributor
Contributor

I just spent hours figuring a workaround to this issue. Completely insane...

Here is what I did:

If you have another version already installed you must uninstall it like this:

  • Go to C:\Windows\Installer
  • Add the "Authors" column and sort by it
  • One of the .msi files with have a "VMware" author
  • Double-click it and follow through with the uninstall steps

Then to install the new version you must extract the installer:

  • Run cmd.exe as administrator with any method... (e.g. type cmd into the search box at the bottom of the start menu and when it shows up right-click on it and select: Run as administrator)
  • Type in "cd the-directory-where-the-install-file-is" then hit enter (e.g. c:\users\bob\downloads\)
  • Type "the-name-of-the-install-file.exe /e tempfolder"
  • Give it a few minutes or so to finish..
  • Go to that new folder (e.g. c:\users\bob\downloads\tempfolder\) and find the .msi file (for VMware Workstation it's named "vmware workstation.msi"), and run it

This worked for me. Good luck.

0 Kudos
Hiro14
Contributor
Contributor

Nice work. Extracting the files from the .exe and running the .msi worked perfectly.   Thanks.  I still don't understand what was the problem.  Why didn't the .exe file run correctly?

0 Kudos
solbirn
Contributor
Contributor

I don't know exactly. My current bet though is, that because the error is jscript.dll - which vmware uses in the .exe installation/update, either microsoft updated a necessary file (i.e. jscript.dll itself or some other related dependency) or some other company did. (Reregistering the dlls didn't help so I tried uninstalling IE9, reverting to the old jscript.dll and that didn't help. I also thought maybe Google Chrome Frame, but uninstalling that didn't help either...) I hope VMware gets on top of it sometime soon. I don't want to have to do this every time there is an update...

0 Kudos
giba201110141
Contributor
Contributor

Thanks man! I did what you did and it worked!Smiley Happy

0 Kudos
MiCaDzgn
Contributor
Contributor

That worked thank you Smiley Happy

0 Kudos
First8
Contributor
Contributor

Hi,

I had the same problem on my Windows 7 machine. During the VMWare Workstation 7 installation the window kept being blank without any information or options except the title in the titlebar.

That's when I found this thread and the suggested workaround. The workaround worked, but still I was not statisfied, because I knew that the installer worked earlier, when I installed VMWare for the first time. So I dug a little deeper and found the root problem for this issue.

One of Microsoft updates screws up the Internet Zone settings in the registry, and this is why Javascript is not called in applications. To fix this open the registry editor

>>> (Start > Run > regedit.exe)

and search the entry

>>> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

There you should have some folders 0, 1, 2, 3 and 4. In my case I had a folder named "L" before the 0.

If you have this, delete the "L" Folder and restart your System.

Afterwards the installer should work again like it's supposed to be.

Hope that helps.

solbirn
Contributor
Contributor

Thanks man.

Great find. I speculate L stands for the "Local" zone.

I can't believe VMware or Microsoft haven't done anything offical yet.

0 Kudos
Greeny_FM
Contributor
Contributor

First8 is right and this works, except it's not "L" letter but "└" (unicode #2514 iirc) symbol
Thank you.

0 Kudos
First8
Contributor
Contributor

Yes, you are right. I just didn't know how to add this character in this forum, so I used the "L" instead.

And I was too lazy to find the right symbol :smileyblush:

0 Kudos
tsilmi
Contributor
Contributor

I checked and there is no L folder Zones 0 to 4 .

Thanks, T

0 Kudos
satya1
Hot Shot
Hot Shot

Hi you are installing through installation disk or ISO image ?

if from disk please check through ISO Image .

1850467.png

_________________________________

Good luck!

This is the answer to your query. Don't forget to give

feedack , which help to others.

http://imagicon.info/cat/5-59/vbsmile.png

0 Kudos
continuum
Immortal
Immortal

at folks reading this - the last post is completely off-topic - just ignore it

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
massada
Contributor
Contributor

I just purchased an upgrade to VmWare WS 8 to load on my i7 lappy for security. I could hardly believe it when I saw the blank gray screen in the install window. I took the easy way out an did a command line install which seemed to take longer than normal, even though I admit to being an impatient soul. Every thing was working fine except the vm install of Win 7 Standard or Thin PC was sluggish whenever it came back up in the GUI. This was resolved by changing from basic to aero theme which led me here searching for a solution which I found in this thread. The hovering L in Zone was in my register.

I could not resist trying it so uninstalled VM WS 8. Took the line out of the registry and all is good. The gray screen was no longer present. Many thanks for the suggestion because this really bothered me, even after I got the vmware WS 8 installed because it suggested to me that something was not right on my Win7 Pro OS. vmware is a great company, but it is vmware users like firs8 (spelling?) that make me appreciate vmware products. I always know the answer is here, and if not will be forthcoming.

0 Kudos