RabAlexander
Contributor
Contributor

Black Screen After login.

Hi everyone,

I want to create a VM of my current Windows installation and use it as a VM for testing, etc. I downloaded and used the "VMware vCenter Converter Standalone Client" to make the VM of my running machine.

I'm planning to run that guest VM in the current VMWare Workstation 16 Player, in Windows 10 host. Maybe Linux host, too.

The VM launched and prompted to install the VMWare Tools, which I did. After I logged in, the screen went black. Darn.

Found a number of references to black screen being associated with Tools, and I should launch the VM in Safe Mode and do some voodoo with the VGA drivers. OK.

From the VMWare article: https://kb.vmware.com/s/article/2034627
last update Jan 2021...

  1. Boot the virtual machine into Safe Mode.
  2. In the Device Manager, change the driver for the VGA card to the standard MS VGA Driver                         Note: How to open Device manager please do check the vendor document
  3. Reboot the virtual machine.
  4. Uninstall the current incorrect version of VMware tools.
  5. Install the latest correct version of VMware tools.

I figured out how to launch in Safe Mode without the "difficult" timing of hitting F8 -- by holding shift while clicking the "Restart" button. (Learn something every day.) πŸ™‚ see: https://www.howtogeek.com/107511/how-to-boot-into-safe-mode-on-windows-8-the-easy-way/

However, once I'm in the VM in Safe Mode, and I go to the Control Panel and click on "Device manager" nothing happens. It simply doesn't launch.

The "VMWare Tools" I installed was the version it downloaded, so I assume it's the current one.

So I'm stuck. I can't make the recommended change because I can't get into the Device Manager.

Any ideas or advice? Thanks a lot.
Rab

0 Kudos
4 Replies
RaSystemlord
Hot Shot
Hot Shot

Don't know for sure, but the typical reason might be that you have 3D Acceleration active in your VM Settings. Turn it OFF.

If you really do need 3D hardware based acceleration, then you need to fiddle with graphics card on your host & both drivers - if this is what your black screen is coming from.

If this is something else and you think that Device Manager doesn't launch - it probably does but it is outside the limited screen area that you see. You need to a) try with another Host, where a larger screen area is working (like that Linux), b) find out the registry entry, where you can change the location of the Device Manager. (If you do try with Linux Host, please observe that NTFS probably does NOT work for your VMware, for instance since Ubuntu 18.04 LTS it does not work. So, you cannot run VM from a USB-3 drive where you copy your Windows located based VM ... you need to further copy it to ext4 filesystem for Linux use.)

0 Kudos
RabAlexander
Contributor
Contributor

hi RaSystemlord, thanks for the response.

I've already tried turning 3D Acceleration off. No joy.

Thanks for the thoughts on Linux, (I agree about the filesystem) but I'm not really concerned with Linux at this point. I'm just trying to get the thing to work as a guest on the Windows host. πŸ™‚

I don't think there's an issue with Device Manager opening "off screen." When I launch in "Safe Mode" the screen size is limited to the small rectangular VMWare window, and all the desktop icons are rearranged to fit in that small space. I don't think there's any more screen outside those boundaries. Other items from the Control Panel open and work normally. Also, if the VMWare window is smaller than the screen it's displaying, there'd be scroll bars.

The quest continues...

Rab

Tags (1)
0 Kudos
RaSystemlord
Hot Shot
Hot Shot

OK, acceleration wasn't the problem.

a)
As for Windows - you might assume that an Operating System named Windows would be capable of managing its windows on the screen, but that is not the case.

The matter might not be about all windows - and certainly not about any menu item - but those windows, which remember their location. I cannot recall if Device Manager on XP was remembering its last position - perhaps you can check that. If it does remember it, it is affected ... IF Safe Mode doesn't work in a different way - but I don't think it does.

The matter is very clear with application windows, which have been programmed to remember their position. Now, you cannot do the easiest approach, use a bigger resolution to relocate the windows.

However, there is one easier approach to this, other than registry edit. If you google the following, you can have tips how to move windows that are off-screen. When you select Device Manager, it is active but not seen (in this scenario) and you can still move it - those are the grounds for the tips to work. Google: "move invisible window windows 10".

Otherwise, I cannot think how Device Manager wouldn't start. Does it start in the source?

b)

As for the problem itself, I think you just got the wrong graphics driver to your VM. If nothing else works, perhaps you can redo the convert and omit that driver in the list (... which list I don't remember what it has, but you can easily check if this is possible or not).

0 Kudos
ender_
Hot Shot
Hot Shot

If you have off-screen windows, you can move them on the screen by pressing Alt+Space, selecting Move from the menu that opens, then press any arrow key on the keyboard - that should move the window back to the screen (if Move is greyed out, select Restore first, then Alt+Space again and Move).

Anyway, if you have black screen after logging in - try pressing Ctrl+Shift+Esc, this should launch Task Manager. Click More details, then check the Details tab if explorer.exe is running. If it is, select it, then choose End task, then File β†’ Run β†’ explorer.exe - if you're lucky, this'll get you your desktop back.

0 Kudos