Contributor
Contributor

Arrow keys not working in Player v2.5 64bits, host=Ubuntu 8.10 64bits, Guest = XP pro 32bits

Jump to solution

My XP (32 bits) VM that works perfectly in VMware Workstation 6.5 (XP host) but now it has the following issues now that I moved it to a fresh new install of:

- Host = Ubuntu 8.10 64 bits,

- VMware Player 2.5.0 build-118166 AMD64, (downloaded the Bundle file)

- Vmware Tools 2.0.0 build 116503

Issues:

None of the standard arrow keys work, neither does Home, PageUp, PageDn, End or Delete, inside the VM. However, the equivalent keys work in the numeric pad with Num Lock on.

The Arrow Down key even displays the Windows Start Menu, so it's behaving like the Windows key (that is between left-ctrl and left-alt).

The Windows key, however, does nothing. All other keys seem fine, like F1..F12, backspace, tab, shift, etc.

The keys that don't work inside the VM work normally in the host OS, both OS and VM are set for English and British layout.

As a programmer, it indicates to me that there is a problem mapping the double key-stroke of those specific functions from the host to the guest, maybe because it's a 64 to 32 bits conversion bug? or a Ubuntu to Windows conversion bug?

If someone from VMware is reading this, please pass this information to the testing or development team .

Any suggestions?

Is there a more recent VMware tools available? If yes, where can I get it from?

Thanks for any help,

Alex.

0 Kudos
1 Solution

Accepted Solutions
Contributor
Contributor

I had the same problem with VMware Server Console on Ubuntu 8.10.

For me worked this:

add line

xkeymap.nokeycodeMap = true

to /etc/vmware-server-console/config

In another forum was a hint to add the above line to ~/.vmare/config

(Could be that it works, too. But I did not test)

View solution in original post

0 Kudos
17 Replies
Contributor
Contributor

I'm running a simlar set up, exact same versions of Player, Guest and Tools and have the same complaints after upgrade to Ubuntu 8.10 64bit and Player 2.5 118166: Arrow keys, page up/down, delete and end keys are all FUBAR. Down arrow acts like the Windows meta key. Willing to try anything at this point, as I run some software for work in a virtual machine that I'm dead in the water without.

0 Kudos
Contributor
Contributor

Ok, I got the solution:

Edit your "/etc/vmware/config" file, so type:

sudo gedit /etc/vmware/config

And add this to it:

xkeymap.keycode.108 = 0x138 # Alt_R

xkeymap.keycode.106 = 0x135 # KP_Divide

xkeymap.keycode.104 = 0x11c # KP_Enter

xkeymap.keycode.111 = 0x148 # Up

xkeymap.keycode.116 = 0x150 # Down

xkeymap.keycode.113 = 0x14b # Left

xkeymap.keycode.114 = 0x14d # Right

xkeymap.keycode.105 = 0x11d # Control_R

xkeymap.keycode.118 = 0x152 # Insert

xkeymap.keycode.119 = 0x153 # Delete

xkeymap.keycode.110 = 0x147 # Home

xkeymap.keycode.115 = 0x14f # End

xkeymap.keycode.112 = 0x149 # Prior

xkeymap.keycode.117 = 0x151 # Next

xkeymap.keycode.78 = 0x46 # Scroll_Lock

xkeymap.keycode.127 = 0x100 # Pause

xkeymap.keycode.133 = 0x15b # Meta_L

xkeymap.keycode.134 = 0x15c # Meta_R

xkeymap.keycode.135 = 0x15d # Menu

Save it and be happy!

0 Kudos
Contributor
Contributor

This is (at this time) a known and common bug, I wish this information was made widely available (and specially acknowledged) by VMware

0 Kudos
Contributor
Contributor

The subject also describes my setup exactly. The day I installed Intrepid Ibex was the day my VMware window started going crazy. RDP to the XP works fine though.

I just installed this keymap to the /etc/vmware/config file and it works after restarting the virtual machine, so killing the player window process and starting it again doesnt fix it, you have to do a full reboot.

I still have a problem with NX (No Machine NXing from Ubuntu to Ubuntu) but that's not a VMWare issue.

Thanks for the fix!

Just noticed that my "print screen" button still maps to delete, but that's not a big deal.

0 Kudos
Contributor
Contributor

Just for reference, exactly the same problem in Workstation 6.5 on Ubuntu 8.10 32 bit, Guest=XP Pro 32 bit.

Same solution worked too, so all good now.

Cheers,

0 Kudos
Contributor
Contributor

For reference, I got the same exact problem when upgrading from Ubuntu Hardy to Intrepid

Main OS : Ubuntu 8.10 32bits, kernel 2.6.27-8-generic, gcc 4.3.2

VMWare version : vmware-server_1.0.8-126538_i386.rpm

RPM converted to DEB with alien (ignoring the preinst/... scripts due to installation errors on Ubuntu)

I also installed the vmware-server-console from the same version packages.

To be able to compile vmware modules correctly under 2.6.27-8, I installed the vmware-update-2.6.27-5.5.7-2 (www.insecure.ws) after the vmware-server debian package installation.

Running Windows XP SP2 as the guest OS had the same "swapped ctrl/arrows/... keys" symptoms.

Installing the above fix in /etc/vmware/config (xkeymap.keycode...=...) solves the issue, apart from the PrintScreen key which is still mapped as Delete... thanks for the fix anyway !! it really is a relief,it was hard to work with such weird mappings Smiley Wink

(I even had the guest OS keyboard mapping customized to be able to use the Windows International Keyboard ALT "cumulative" feature along with a dvorak keyboard... and the symptoms were the same, and the fix works the same way as with a standard keyboard mapping)

jcf

0 Kudos
Contributor
Contributor

I had the same problem with VMware Server Console on Ubuntu 8.10.

For me worked this:

add line

xkeymap.nokeycodeMap = true

to /etc/vmware-server-console/config

In another forum was a hint to add the above line to ~/.vmare/config

(Could be that it works, too. But I did not test)

View solution in original post

0 Kudos
Contributor
Contributor

Well, I found the suggestions here very useful. The last suggestion of adding the

xkeymap.nokeycodeMap = true

to my /etc/vmware/config file works for the latest Workstation and Player (and easier than all of the keymaps farther up).

later,

scott

Enthusiast
Enthusiast

For those of you using VMware Server 2.x on Fedora 10 and having problems with the arrow keys and other keys, this solution works on F10 as well.

Contributor
Contributor

Does anyone know how to fix this when the host = XP pro and the guest is Ubuntu 8.10?

Thanks...

0 Kudos
Contributor
Contributor

Not sure how to fix it keys problem if host is XP pro. My host is Ubuntu 8.10. Thanks to AlexPX, the problem with arrow keys not working is fixed now.

Thanks a lot.

0 Kudos
Contributor
Contributor

xkeymap.nokeycodeMap = true

This is not a full solution.

I have Swedish keyboard layout in the ubuntu 8.10 host. In the winxp guest it seems I have english layout even though it is set to Swedish.

AlexPX solution fixes this.

0 Kudos
Contributor
Contributor

for fixing the "Print Screen" key, which is mapped to the "Del" key, add this to your vmware config file (tested for /etc/vmware/config):

xkeymap.keycode.107 = 0x137 # Print Scrn

see:

http://www.vmware.com/support/ws5/doc/ws_devices_keymap_linux_longer.html

http://www.vmware.com/support/ws5/doc/ws_devices_keymap_vscan.html

0 Kudos
Contributor
Contributor

I had the exact same problem when using Fedora Core 10 as the host OS and Windows XP Pro as the guest. The fix suggested in this thread (adding "xkeymap.nokeycodeMap = true" to /etc/vmware/config) did the trick and my arrow keys are working again. Still, I hope VMWare fixes the underlying issue so that we don't have to look up and resolve these little bugs ourselves. Still, VMWare workstation is a truly great product--keep up the good work!

0 Kudos
Contributor
Contributor

Unfortunately, it doesn't work for me.

Host: Ubuntu 8.10 64-bit with all updates installed

Guest: Ubuntus 32-bit

Remote console computer: Kubuntu 8.10 with all updates

I applied both fixes to /etc/vmware/config on Host computer, restarted vmware completely, rebooted my host, even reinstalled remote console FF add-in on Remote Console computer. Still can't get arrow keys etc. working Smiley Sad

Any ideas, how to fix it?

Thanks in advance,

Marek

0 Kudos
Contributor
Contributor

What's written down here is NOT the solution.

I tried to add all the mentioned options to vmware2 server's config file then restart it, but didn't help.

The arrow keys still didn't work. I pulled back the backup of vmwares config from months ago (when it worked perfectly) and nothing changed in it.

So if someone figured out what causes this please answer. Its just god damn annoying that this happens in production because of no obvious reason.

Here the guy writes down the same options which doesn't work again:

http://www.finalcog.com/vmware-arrow-keys-ubuntu-8.10-intrepid

0 Kudos
Contributor
Contributor

I'm using Ubuntu Server 10.10

All I did was

sudo dpkg-reconfigure console-setup

And changed they keyboard model from EvDev handled to the Generic 105-key option (and Swedish layout, personal preference).

Now all my keys (including arrows, print-screen etc.) works as expected.

0 Kudos