zenficus
Contributor
Contributor

All USB devices are greyed out

Jump to solution

All USB Devices are greyed out.

VMWare Tools installed, both on host and guest.

VMWare Wrkstation Player: 16.2.1

VMWare Tools: 11.3.5

Host OS: Windows 10 21H1 x64

Guest OS: Windows 7 SP1 x86

VMWare USB Arbitration Service is running, never stopped.

Device that I want to redirect is named "Ethernet Gadget", connected to USB 2.0, USB controller in VM's setting also 2.0.

VM just has been created in this version of VMWare Workstation Player.

 

What could be the root of the problem?

What additional logs could help to resolve the problem?

zenficus_2-1636972399357.png

 

zenficus_1-1636972356731.png

 

 

1 Solution

Accepted Solutions
zenficus
Contributor
Contributor

I found the solution!

Thanks @CarltonR for idea to check behavior of other VMs, and good that I'e had one.

I've compared configuration files for two VMs mentioned before: created in older version of VMWare Workstation and newest one (at the moment 16.2.1). There were some differences caused by a way of creating VM (I suspect that I've created old one without using VMWare's Easy Install), but that's not the case, I assume.

I've found one very interesting line in "*.vmx" configuration file:

usb.restrictions.defaultAllow = "FALSE"

It's very interesting because looks like it has been added automatically in the VM creation process, and it is NOT configurable from the GUI. I am considering this as a major flaw, but don't know how to report that problem to VMWare bug-tracking team. Also, there's not enough documentation about configuring VMs directly in "*.vmx" files, all of the docs I've seen so far are explaining configuration in GUI only.

After deleting this line from VM's configuration file all listed USB devices became able to be connected to VM. Problem solved.

 

tl;dr

Open VM config file (with ".vmx" extension) with a text editor, find line mentioned above and delete it completely. Do this when VM is powered off.

View solution in original post

26 Replies
CarltonR
Hot Shot
Hot Shot

Is this happening for all Guests or just this one ?

 

But suggest confirming, under the Settings - Hardware tab for the Guest [Win 7] in question that there is a 'USB Controller' entry present on the list of Devices.

zenficus
Contributor
Contributor

>But suggest confirming, under the Settings - Hardware tab for the Guest [Win 7] in question that there is a 'USB Controller' entry present on the list of Devices.

Yes, I haven't touched it at all, didn't removed and added again, it's there, I can choose 1.1, 2.0 & 3.1 versions of USB.

 

>Is this happening for all Guests or just this one ?

That was a very good question!

I moved this VM to laptop and tried to launch it there - no luck, same problem.

But, on the laptop I've had previous VM, created in another version of Workstation 16. I can't say it's version because I've upgraded application version to the same that I'm using on desktop.

So, USB redirection works in other VM without any problems! And that's weird.

Same settings for USB controller.

The only difference I've noticed: "Version" field in VM's description.

Old & functional one has "Workstation 16.x virtual machine", when new one has "Workstation 16.2.x virtual machine".

Anyways, it's just giving us hint, but not solves the initial problem: non-functional USB redirect on new VM. Of course, I could download older version of Workstation 16, but to check if it's working - I should install OS completely, update it (because several drivers from VMWare Tools are signed with SHA-2 which is not supported natively by Win7 SP1), install VMWare Tools and only then - check if it works. Looks to me like a useless effort, but I could be wrong.

zenficus
Contributor
Contributor

I found the solution!

Thanks @CarltonR for idea to check behavior of other VMs, and good that I'e had one.

I've compared configuration files for two VMs mentioned before: created in older version of VMWare Workstation and newest one (at the moment 16.2.1). There were some differences caused by a way of creating VM (I suspect that I've created old one without using VMWare's Easy Install), but that's not the case, I assume.

I've found one very interesting line in "*.vmx" configuration file:

usb.restrictions.defaultAllow = "FALSE"

It's very interesting because looks like it has been added automatically in the VM creation process, and it is NOT configurable from the GUI. I am considering this as a major flaw, but don't know how to report that problem to VMWare bug-tracking team. Also, there's not enough documentation about configuring VMs directly in "*.vmx" files, all of the docs I've seen so far are explaining configuration in GUI only.

After deleting this line from VM's configuration file all listed USB devices became able to be connected to VM. Problem solved.

 

tl;dr

Open VM config file (with ".vmx" extension) with a text editor, find line mentioned above and delete it completely. Do this when VM is powered off.

CarltonR
Hot Shot
Hot Shot

If I understand it correctly, this is only occurring on this particular Guest and not any of the other ones you have.  And, that when this Win 7 Guest is moved to another machine (laptop) the USB devices are also greyed out.  

This would then imply that the issue is with this particular Guest.  May I then suggest a couple of things:

  • Create a new VM with Win7 and see if this is the same.
  • take a look at the .vmx files for this Guest and compare it with a VM that is working, ideally another Win 7.

It's not entirely clear from the description as to whether this has only recently occurred or always been the case, or whether this is a newly created VM.

However, with regards to whether it's related to the Workstations Player version . . . as an exercise I dusted off a copy of Win 7 Pro SP1, and created a VM on Workstation Player 16.2.1 and was able to present a USB drive, both with, and without the Tools installed on the Guest OS.

CarltonR
Hot Shot
Hot Shot

. .  . well done, that good news.

0 Kudos
zenficus
Contributor
Contributor

Did you used "Easy Setup" feature? As far as I know, it's taking responsibility of configuring Windows during installation with paramerets that you're setting. The issue could happen during this automatic configuration. From the other side: issue is not in Windows setup or OS config, it's in VM config, so maybe Easy Setup is not is not affecting VM's config file in a way of adding above mentioned line.

Also could be helpful: do you have this line in *.vmx config file? Maybe the value has been set to "TRUE" on your side.

Anyways, it's an undocumented configuration parameter that couldn't be changed in GUI. Googling this parameter gave me nothing. It is not mentioned in VMWare Docs. There is no way of knowing what is blocking USB redirection in case you don't have other fully functioning VM. So, is there a way to report issue to knowledge base or something similar?

0 Kudos
jormathog
Contributor
Contributor

I just upgraded to 16.2.1 build-18811642 and created a new virtual machine and had the same exact USB issue as you. I've been trying stuff from different forums and confirming my settings and nothing worked

I changed from:

usb.restrictions.defaultAllow = "FALSE"

To:

usb.restrictions.defaultAllow = "TRUE"

 and this worked for me. Thank you for the advice.

KraakBal
Contributor
Contributor

same thing.. New Ubuntu guest VM with 16.2.1 cannot connect any removal USB device. VMWARE PLS FIX

0 Kudos
pscrubs
Contributor
Contributor

Removing this line resolved the issue for me as well (Workstation 16.2.1 on Windows 11).

0 Kudos
Suryavarman-II
Contributor
Contributor

I have the same problem too. I just updated VMware Workstation Pro to 16.2.2 build-19200509. I created a new openSUSE Linux VM and the option to connect a USB flash drive was greyed out.

Your solution by editing the "VMware virtual machine configuration (.vmx)" file works.
However, VMware needs to fix this so we don't have to manually edit the configuration file.

0 Kudos
GeriZsolt
Contributor
Contributor

Hi

I have the same problem, however the fix is not working for me, since my vm is encrypted so the config file too. 

Is there any way to still edit the config file?

0 Kudos
nursereese
Contributor
Contributor

In what folder were you looking for the config file? 

At first I was looking in the VMWare program directory and the only file with vmx anywhere was a .exe file.

Where I found was under the following path C:\Users\*****\Documents\Virtual Machines\(whatever you have named your virtual machine)

This is where the .vmx file with the editable line - usb.restrictions.defaultAllow = "FALSE" - was located

My virtual machine is named Windows 8.x x64 (yes, very original) so the file is named - Windows 8.x x64.vmx

0 Kudos
b0bcat
Contributor
Contributor

THANK YOU, Zenficus! I have been looking for this solution for a long time. That was exactly what I needed. 

0 Kudos
MattLedz186
Contributor
Contributor
Spoiler
I created an account just to give you Kudos! I've been scrolling through forums for 20 minutes, and all that gave me was "reinstall VMware tools". I didn't think to check the configuration file. I removed the line, and sure enough, it worked for me. Thank you!!
0 Kudos
PhilC8
Contributor
Contributor

On 6/1/2022, I just installed the latest version of Workstation Pro and Player, both have USB devices greyed out. Where are the VMware's developers? Why does VMware not acknowledge this issue and not fixing it? It is so hard to find good technical support from the vendors.

Thanks for getting us the solution.

 

0 Kudos
KraakBal
Contributor
Contributor

Yes still broken for me also yesterday, after months of waiting for fixes.

Crap software. Going to move to dual boot again.

0 Kudos
KraakBal
Contributor
Contributor

And various other issues with window resizing, USB drives connected to it are super slow and freezes, only dx10.2, wtf.

0 Kudos
mc0123
Contributor
Contributor

You saved the day!!!!

0 Kudos
mccastle
Contributor
Contributor

Had this issue too.  Windows 11 host.  Debian 11 guest.  VMware Workstation Player v16.2.4 Used the quick vm setup.  USB devices plugged into the host were visible but greyed out.  Could not connect to them.  Tried removing the USB controller and adding it back in the GUI vm settings but that did not work.  Changing that line in the vmx file to "TRUE" solved my problem.  Thank you for sharing this!

0 Kudos