urbangibbon
Contributor
Contributor

3d graphics disabled

Jump to solution

Hi. When I start my Windows XP Virtual machine I get the following message.

3D graphics acceleration will be disabled. This computer does not have a

3D graphics system supported by VMware Player

How can I enable 3D acceleration?

My system is as follows:

VMWare Player 3.1.0 build-261024

Host: Ubuntu 10.04

Guest: Windows XP

Computer: Toshiba Satelite Pro A120

Thanks for any help

0 Kudos
1 Solution

Accepted Solutions
dragongc
Enthusiast
Enthusiast

Ubuntu software center > install driconf

System > Preferences > 3D acceleration > Image Quality > Enable s3tc texturing.

Should work now Smiley Happy

Cheers

View solution in original post

0 Kudos
10 Replies
admin
Immortal
Immortal

Your Ubuntu host's graphics driver does have the capabilities for VMware Player to support 3D. The vmware.log will provide some information as to what is missing.

urbangibbon
Contributor
Contributor

Thanks for the response. I have attached the log file. I am afraid I don't know what to look for.

Any further help will be appreciated.

0 Kudos
admin
Immortal
Immortal

vmware.log

...

Jun 30 23:16:13.648: mks| OpenGL Version: "1.4 Mesa 7.7.1" (1.4.0)

Jun 30 23:16:13.648: mks| OpenGL Vendor: "Tungsten Graphics, Inc"

Jun 30 23:16:13.648: mks| OpenGL Renderer: "Mesa DRI Intel(R) 945GM GEM 20091221 2009Q4 x86/MMX/SSE2"

...

Jun 30 23:16:13.651: mks| GLManager: Required extension GL_EXT_texture_compression_s3tc is missing.

...

Jun 30 23:16:13.662: mks| 3D graphics acceleration will be disabled. This computer does not have a 3D graphics system supported by VMware Player.


See .

0 Kudos
urbangibbon
Contributor
Contributor

Thanks for the response.

As I am a bit of a linux novice, I need to ask further questions. Sorry.

0 Kudos
admin
Immortal
Immortal

VMware Player on Linux requires S3TC to support 3D, but the Intel graphics driver on your Ubuntu host does not support S3TC.

See http://dri.freedesktop.org/wiki/S3TC for further reading.

0 Kudos
urbangibbon
Contributor
Contributor

Apologies. My full question did not get posted previously.

Are you saying that I cann't resolve this problem? Or can I install a driver from that website you have linked?

If yes to the second option, what and where do I install it? e.g. is it libtxc_dxtn040524.tar.gz ? Where and how on my laptop?

Thanks again

0 Kudos
dragongc
Enthusiast
Enthusiast

Ubuntu software center > install driconf

System > Preferences > 3D acceleration > Image Quality > Enable s3tc texturing.

Should work now Smiley Happy

Cheers

0 Kudos
urbangibbon
Contributor
Contributor

Thank you. That has worked fine.

0 Kudos
MarkSpanner
Contributor
Contributor

@dragongc Thanks! :smileygrin:

3D acceleration is now available on my VMs:

VMware Workstation 7.1

Ubuntu 10.04 Host

HP 6730b laptop

0 Kudos
felipunk
Contributor
Contributor

Hi dragongc.

I just wanted to let you know that your workaroud worked great also in Ubuntu Natty with Intel i5 chipset (I didn't find the graphics card identifier anywhere), and just to add one more thing.... If you perform that change in a VM that was suspended, it won't take effect until you shut down the VM OS completely.

Anyway, thanks again!

0 Kudos