Highlighted
Contributor
Contributor

Question: Cannot deploy VM's from Template

Hi

A Few monthis ago we did implement VMware in our environment with 2 hosts and an equallogic controller. Most of the machines were migrated across and we had 2 templates for window 2008 R2 setup by the consultant. I started using the templates to deoploy new VM's. I notice that I cannot deploy any VM's from this template as it complains with an error message as shown in the attached word doc. Upon looking closely, I could see from the vmx file of one of the Virtual machines deployed may be sharing this template, It looks like it has some reference to the template.vmdk file, I have copied the whole .VMX file in the word doc. The original template was set with windows 2008 on a 40 GB HDD. The Virtual machine which was deployed was changed to 120 GB HDD. Now seeing at the datastore the deployed VM has a 40GB vmdk file and the template originally used has 120GB. Everything is working fine but I want the deployed VM to be only pointing to the relevant .vmdk file and loose the connection with the template without disrupting my server. what is the best way to do this, I am fairly new to VM environment.

Also when I deployed the VM originally,  I Right clicked the relevant template and selected the option "Deploy Virtual machine from this template" I presume that is the option to be used.

0 Kudos
1 Reply
Highlighted
VMware Employee
VMware Employee

Please go through this post. this will help you resolve your issue.

https://communities.vmware.com/message/2048677

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos