tpallone
Contributor
Contributor

Windows 10 1709 -VMRC 10.0.2 build-7096020 and FoxTrot (RPA) robotic process automation

Jump to solution

Hello All,

Hopefully someone might can answer this..Here is the background information.

We configured a Windows 10 Pro -1709 VM and installed the latest VM Tools. We have another application on the VM, FoxTrot (RPA) robotic process automation which is a bot that handles inputting information into another application without human intervention.

I have VMRC 10.0.2 on my computer to basically monitor the Windows 10 VM to make sure the RPA is working properly.

The problem is that sometimes my keyboard and mouse actions on my desktop interfere with the VMRC Windows 10 VM while the "Bot" is running.

My mouse and keyboard are not locked into the VMRC window like they used to be with previous versions.

I do not have to hit Crtl-Alt to release from the window at all..

I am looking for a way to turned that back on just for this one VM, since it will be running the RPA.

Is this possible?

Hopefully, I got my question across,I am new to this and will be attending VM Vsphere class in two weeks to learn more.

Thanks,

0 Kudos
1 Solution

Accepted Solutions
CQuartetti
Hot Shot
Hot Shot

I think turning off automatic "ungrab" will do what you want. If you're using Workstation you can change this from Edit>Preferences, Input, uncheck the box "Automatically grab and ungrab the mouse".

VMRC (and Player) don't have this UI option, but you can manually edit the preferences file to change it (thanks to James Lin's SuperUser post😞

  • Close running VMRC/Player instances
  • Edit the preferences file (%APPDATA%\VMware\preferences.ini on a Windows host, ~/.vmware/preferences on Linux)
  • Add the line
    • pref.motionUngrab = "FALSE"

View solution in original post

0 Kudos
2 Replies
CQuartetti
Hot Shot
Hot Shot

I think turning off automatic "ungrab" will do what you want. If you're using Workstation you can change this from Edit>Preferences, Input, uncheck the box "Automatically grab and ungrab the mouse".

VMRC (and Player) don't have this UI option, but you can manually edit the preferences file to change it (thanks to James Lin's SuperUser post😞

  • Close running VMRC/Player instances
  • Edit the preferences file (%APPDATA%\VMware\preferences.ini on a Windows host, ~/.vmware/preferences on Linux)
  • Add the line
    • pref.motionUngrab = "FALSE"

View solution in original post

0 Kudos
tpallone
Contributor
Contributor

That was perfect ...

Thanks a ton.

0 Kudos