Mickeybyte2
Hot Shot
Hot Shot

VMware Remote Console 11.0 - connection error

Jump to solution

I just got the message that there's a new version of the vmware remote console available. I installed version 11.0  on both a Windows 10 and Windows Server 2012R2 and now I'm unable to connect to the console of my VM's anymore.

If I start the Console, it opens up fine but with a black screen. after some time I get an error: Connection error. I can pause, stop, start the VM from the console without problems, but I don't have any visible console, just a black screen.  (vCenter used is 6.7.0)

Anyone else has the same problem?

Thanks,

Michiel

Regards, Michiel.
Tags (1)
1 Solution

Accepted Solutions
shareandgain
VMware Employee
VMware Employee

VMRC requires the accessibility of ESXi's 902 port until the VMRC 11.0, which requires the accessibility to ESXi's 443 port instead.

Basically, you can either

* unblock the ESXi's 443 port

* or adding the following configuration in the preference file(C:\Users\<user>\AppData\Roaming\VMware\preferences.ini), it will make VMRC fall back to legacy connection type

   pref.preferWebMKS = "FALSE"

Thanks!

View solution in original post

8 Replies
shareandgain
VMware Employee
VMware Employee

Hi Mickeybyte2,

Could You help share the VMRC logs? Their locations can be found in VMRC > Help > About VMware Remote Console.

Please share both vmware-vmrc-XXXX.log and vmware-XXXX-mks-YYYY.log

May I know if the ESXi host's 443 port accessible from the VMRC's host PC?

Thanks!

Mickeybyte2
Hot Shot
Hot Shot

Hi,

No, the ESXi hosts are not accessible, only the vCenter is accessible for us on port 443.

I've attached the logs (masked IP's and domains) and I do see indeed it wants to connect to a host on port 443, which is not working... It worked before with version 10.0.6 without any problems.

Michiel.

Regards, Michiel.
0 Kudos
shareandgain
VMware Employee
VMware Employee

VMRC requires the accessibility of ESXi's 902 port until the VMRC 11.0, which requires the accessibility to ESXi's 443 port instead.

Basically, you can either

* unblock the ESXi's 443 port

* or adding the following configuration in the preference file(C:\Users\<user>\AppData\Roaming\VMware\preferences.ini), it will make VMRC fall back to legacy connection type

   pref.preferWebMKS = "FALSE"

Thanks!

View solution in original post

Mickeybyte2
Hot Shot
Hot Shot

Thanks for the quick reply! I've tested it with the preferences.ini and it's working again.

I'll ask our service provider to adjust the firewall rules to allow port 443 access on the ESXi hosts.

Michiel

Regards, Michiel.
Mickeybyte2
Hot Shot
Hot Shot

Maybe this information can be added to the release notes for version 11 because I can't find this information anywhere else?

Michiel.

Regards, Michiel.
Sheila5507
Contributor
Contributor

Thank you! This worked for me as well.

0 Kudos
shareandgain
VMware Employee
VMware Employee

Hi All,

We just published a KB to explain the new requirement about ESXi's 443 port and how to fix the issue (thanks, Mickeybyte2​ !)

The KB is here VMware Knowledge Base

Thanks

KenSmithKenSmi1
Contributor
Contributor

Any chance there is a pref file to modify for the macOS client?

Edit: Perhaps I should read the KB article. :smileyplain:

0 Kudos