CraigD
Enthusiast
Enthusiast

VMRC will not launch from Web interface on 6.5 using Windows 10

ESXi 6.5 U2 platform.  Client computer is a VDI VM running Windows 10.  Using the Web interface (Flash) in IE to manage VMs, if I click Actions | Open Console I get a new web page tab in IE with a URL that looks something like this:

vmrc://clone:cst-VCT-5218667c-5fcb-5198-61d2-67679471f1a1--tp-CD-CB-00-21-AB-EB-FC-94-63-CD-42-E9-A7-F3-BE-5F-CD-8E-DE-7A@<vcenter FQDN>:443/?moid=vm-520752

I can see the console if I choose to open the web console.  The VMRC is installed.  Setting it as the default console does not alter the behavior.

What's going on?

Tags (1)
4 Replies
CraigD
Enthusiast
Enthusiast

I am guessing the mechanism that tells Windows which program to use to launch/handle certain protocols is broken.  In the "Choose default apps by protocol" list I expect to see "vmrc://", as that is the protocol specified in the URL for opening a remote console.  However, that protocol isn't listed and I don't immediately see how to add it.  I'm continuing to look...

0 Kudos
shareandgain
VMware Employee
VMware Employee

Hi CraigD,

I don't have a 6.5 env right now, could you please try the solution mentioned here, if it doesn't work or not make you satisfied, please let me know, I will do more investigation Smiley Happy

0 Kudos
CraigD
Enthusiast
Enthusiast

Thanks for the response.  I didn't really see any proposed solution in that thread.  I can already launch the Web console. 

There are no popups being blocked.

I (re)set the default console but that produced no change.

Did I miss a suggestion there?  Thanks again!

0 Kudos
dreadnaughtsec
Contributor
Contributor

Set-Item HKLM:\SOFTWARE\Classes\vmrc\DefaultIcon -Value '"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe",0'
Set-Item HKLM:\SOFTWARE\Classes\vmrc\shell\open\command -Value '"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe" "%1"'