LehiCity
Contributor
Contributor

FIX: After Workstation 11 install "Open with VMRC" opens in Workstation

After installing VMware Workstation 11, my "Open with VMRC" links in the vSphere Web Client started opening in Workstation 11. This is actually kind of cool, but I prefer to have it use the regular VMRC. Noticed that 7.0.1 of VMRC was released on February 11th. Installing 7.0.1 fixed my "Open with VMRC" problem. Just thought I would pass this along in case others were struggling with the same thing.

There are no release notes that I was able to find on 7.0.1. Does anyone know if one exists?

11 Replies
PK3030
Contributor
Contributor

Experienced the same on installation of Workstation 11.  I did not think it was "cool" and all! 

VMRC is superior in most aspects for administrating vSphere clients and I don't appreciate a Workstation installation hijacking all my links (I have a lot of them)!

Reinstallation of VMRC (7.0.1) repaired functionality for me as well.  Although I had to recreate all the links to reset the Icon to VMRC - thanks for wasting a chunk of my time VMware!

Workstation should at least ASK if it should supplant VMRC as the default application on installation and IMHO it should default to NO!

CQuartetti
Hot Shot
Hot Shot

Thanks for your feedback. We are planning to revise how these applications register to handle vmrc:// URLs and will be sure this scenario gives more agreeable results. (Tracking with internal ticket #1297503.)

0 Kudos
CBersche
Contributor
Contributor

I agree.  I have Workstation on my machine for specific reasons, but don't really want to use it for my remote console.  After installing Workstation 12, my VMRC got taken over as well, and hopefully this will work to resolve for me as well, as I want to go back to using the Remote Client for what it was designed for.  I too with Workstation had a Preference or configuration option to control this.

0 Kudos
eddyccl
Contributor
Contributor

Having Workstation 12 installed on my laptop and it is annoying because I selected open the VMRC link with workstation when it prompt for the first time after Installed VMRC 7.0.1 and I could not find a way to clear the default. I've been forced to use firefox to open web client to avoid VMRC linked open by Workstation ever since that.

Now upgrading to VMRC 8.0 solved the issue. No more prompt box and it straight away open in VMRC console.

0 Kudos
VMFan82
Contributor
Contributor

I just installed Workstation 12 after running VMRC for years and ran into the same problem.

The way I managed to fix this was to uninstall the VMRC client from Settings: Apps/Features (on Windows 10) and then reinstall it.

The file association went back to the way it was after the reinstall was complete.

I tried messing around with my default application settings and file associations, but ended up wasting a lot of time.

The reinstall only takes a couple of minutes and did the trick.

Hope this works for others as well.

0 Kudos
V_Peter_S
Enthusiast
Enthusiast

I want to confirm post by VMFan82 - re-install of VMRC resolve the issue of my vCSA VMs opening in Workstation 12.

I was heading toward that on my own when I caught the post!

Thanks, Good OnYa.

Esse Quam Videri
0 Kudos
CQuartetti
Hot Shot
Hot Shot

One workaround is to repair the VMRC installation (Windows Control Panel>Uninstall or change a program, choose VMware Remote Console, click Repair). This has the same effect as reinstalling VMRC.

Alternately, it's easy to change in Firefox:

  • Tools>Options (you may need to press "alt" to show the menu bar)
  • Applications, type "vmrc" in the search box
    • In the Action column, click the pulldown and pick an option:
      • Choose a new default program
      • Application Details lets you remove any previously-used handlers so they won't show up in the list if you choose Always ask
      • Always ask


Other browsers are less straightforward.

csmith70
Contributor
Contributor

I too experienced this issue, not only after installing Workstation 12.5, but also after updating it.  I found the following quick fix that starts working immediately.

The following PowerShell commands will correct the issue.  If you are not comfortable with PowerShell, you can navigate to these paths in regedit.  NOTE: It is always best to backup the registry before making changes.

vmrc-before.png                                                                                                                                                                                                                                                     

Set-Item HKLM:\SOFTWARE\Classes\vmrc\DefaultIcon -Value '"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe",0'

Set-Item HKLM:\SOFTWARE\Classes\vmrc\shell\open\command -Value '"C:\Program Files (x86)\VMware\VMware Remote Console\vmrc.exe" "%1"'

After running the commands:

vmrc-after.png

If you launch a VMRC link, it will open in VMRC again and not Workstation - no restarts required.

0 Kudos
rmancl
Contributor
Contributor

thank you csmith for the information.  I created a reg file using your information.  I thought some might find it useful so I am attaching it here.

Here is what it contains if you can't download it.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\vmrc]

"UseOriginalUrlEncoding"=dword:00000001

"URL Protocol"=""

@="URL:VMware VMRC Protocol"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\vmrc\DefaultIcon]

@="\"C:\\Program Files (x86)\\VMware\\VMware Remote Console\\vmrc.exe\",0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\vmrc\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\vmrc\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\vmrc\shell\open\command]

@="\"C:\\Program Files (x86)\\VMware\\VMware Remote Console\\vmrc.exe\" \"%1\""

jacobjbelcher
Contributor
Contributor

This fixed it perfectly. Thank you very much!

0 Kudos
dnswes
Contributor
Contributor

I used the registry file, and it worked well.

I'm running VMware Workstation 14.1.1 and VMRC 10.0.2 on Windows 7 x64 Professional, and have wrestled with this issue a few times.

Reinstalling VMRC did not resolve it in my case, even after uninstall/reboot/reinstall.

Got some sleep back...  Thanks!

0 Kudos