Expert
Expert

supress mitigation esxi powercli

any idea how to suppress this message on a host after lastest patch

Screen Shot 2018-09-25 at 8.25.14 AM.png

5 Replies
Immortal
Immortal

Would you please do at least one search before posting new threads? You do this constantly and one Google search yields perfectly fine results.

https://kb.vmware.com/s/article/57374

0 Kudos
Leadership
Leadership

I think Chip's reply might be a bit harsh :smileygrin:

There is indeed quite some information available on how to suppress the message, but the KB only mentions a manual method (shame on you KB :smileygrin:).

And since this is a community around 'automation', and since changing it in an automated way is not so straight-forward (at least it wasn't to me), attached a script I use.

$arg = @{

  option   = '/UserVars/SuppressHyperthreadWarning'

  intvalue = 1

}

Get-VMHost | ForEach-Object -Process {

  $esxcli = Get-EsxCli -VMHost $_ -v2

  $opt = $esxcli.system.settings.advanced.list.Invoke() | where {$_.Path -eq '/UserVars/SuppressHyperthreadWarning'}

  if ($opt) {

   if ($opt.intvalue -ne 1) {

   $esxcli.system.settings.advanced.set.Invoke($arg)

   }

   else {

   Write-Output "Setting already correct on $($esxcli.VMHost.Name)"

   }

  }

  else { 

   Write-Output "Setting not present on $($esxcli.VMHost.Name)"

  }

}


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

Immortal
Immortal

I think the point I was making was that suppress isn't a "fix" for the issue and if the KB was read there is a solution to the issue.

0 Kudos
Leadership
Leadership

I fully agree Chip, but the "fix" requires a reboot, and not all environments allow such reboots whenever.

The message suppression can eventually be executed till the fix + reboot is done.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Contributor
Contributor

# Retrieve value

Get-VMHost myhost | Get-AdvancedSetting -Name 'UserVars.SuppressHyperthreadWarning' | Select Name,Value,Entity

# Set the value

Get-VMHost myhost | Get-AdvancedSetting -Name 'UserVars.SuppressHyperthreadWarning' | Set-AdvancedSetting -Valuie 1

0 Kudos