Highlighted
Contributor
Contributor

move-vm parameter to empty write-through-cache

Jump to solution

I search for a parameter which sets the option not to migrate cache entries of vm's which are migrated between hosts with virtual flash read cache.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
User Moderator
User Moderator

Afaik this only works when you call the RelocateVM_Task method.

In the VirtualMachineRelocateSpec object, in the deviceChange property, you create a VirtualDiskConfigSpec object for each disk that has cache enabled (make sure to the operation property to edit).

In that object you have a property named migrateCache, that accepts $true or $false.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
1 Reply
Highlighted
User Moderator
User Moderator

Afaik this only works when you call the RelocateVM_Task method.

In the VirtualMachineRelocateSpec object, in the deviceChange property, you create a VirtualDiskConfigSpec object for each disk that has cache enabled (make sure to the operation property to edit).

In that object you have a property named migrateCache, that accepts $true or $false.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos