tuensel2k
Contributor
Contributor

iscsi software initator

Jump to solution

Hello Smiley Happy

is there a way to enable the Software ISCSI Initator on an ESXi 4.1 Host?

I was playing arround with the commands -Get / -Set-VMHostHba but it dosen´t work.

Another problem is that i have to identify number of the vmhba cause i´m using diffrent hardware models, i tried following command:

$iscsi = Get-VMHostHba -VMHost $vmHost | where {$_.Model -like "iSCSI Software Adapter"} | Select Device but $iscsi is always returning "null"

It would be great if sombody could help me with this two little probs.

Thanks in advance Smiley Happy

0 Kudos
1 Solution

Accepted Solutions
LucD
Leadership
Leadership

Strange, works for me.

Did you do a

Get-VMHostStorage $vmHost | Set-VMHostStorage -SoftwareIScsiEnabled $true

to enable iScsi ?

Does this return anything that says "IScsiHbaImpl" ?

Get-VMHostHba -VMHost $vmHost | %{$_.GetType().Name}

Do you see a HBA with a status "unbound" ?

Get-VMHostHba -VMHost $vmHost | Select Name,Status

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
2 Replies
LucD
Leadership
Leadership

Strange, works for me.

Did you do a

Get-VMHostStorage $vmHost | Set-VMHostStorage -SoftwareIScsiEnabled $true

to enable iScsi ?

Does this return anything that says "IScsiHbaImpl" ?

Get-VMHostHba -VMHost $vmHost | %{$_.GetType().Name}

Do you see a HBA with a status "unbound" ?

Get-VMHostHba -VMHost $vmHost | Select Name,Status

____________

Blog: LucD notes

Twitter: lucd22


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

0 Kudos
tuensel2k
Contributor
Contributor

Hey LucD,

I just was missing -SoftwareIScsiEnabled

Now my script is working fine

Thank you Smiley Happy

0 Kudos