Highlighted
Hot Shot
Hot Shot

implemeting vsphere best practices and features_powercli

Jump to solution

Hi Luc,

i have been trying to implement  vsphere best practices and new features on vmware environment using powercli .

i am in process of checking following and thought of discussing with you if we can  add additional features in following list.

1:content Library

2:vcenter high availability

3:virtual machines encryption (that need KMS server i think that incur cost to customer)

4:file based backup(needs location of ftp server)

5:per vm evc

6:enhanced link mode

7:i am planning to do this with powercli 11.5 and posh ssh module .

78 Replies
Highlighted
Hot Shot
Hot Shot

Hi Luc ,

just thought of asking about below  though i can change this password of user in d users and computers but

this exception message did not stop creating the user it just that it giving some password lenght policy .is that correct.??

pastedImage_0.png

0 Kudos
Highlighted
User Moderator
User Moderator

Yes, the user is created with the Create method you called earlier.
But the new password is not accepted due to the complexity rules.


Did you already check with Get-ADDefaultDomainPasswordPolicy what the password rules are?
That cmdlet is in the ActiveDirectory module which should be installed with the RSAT package.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

but for some resaons password is accepted though it threw exception .iam currently using that and it works fine.

0 Kudos
Highlighted
Hot Shot
Hot Shot

HI Luc,

i was checking content library craetion .it is created but for some reasons following wont work ..

pastedImage_0.png

0 Kudos
Highlighted
User Moderator
User Moderator

This might be a permission issue.

Access to Content Libraries is controlled by permissions on the global root.

See Hierarchical Inheritance of Permissions for Content Libraries

Are you connected as the Administrator in the OSS domain?

If another user, have a look at Sample User Role for Working with Content Libraries

PS: I get the same error when connected with a user that does not have that Role.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

i have using

administrator@regionA.local .

this issue happened just now  .it was working fine yesterday and today morning .

0 Kudos
Highlighted
User Moderator
User Moderator

I assume that this happened in a new lab, a new instance?
When you start again with a new lab, does the error come back?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

no it happend on the same lab .however i will be opening new threads for futher questions .

and i m thankful for you massive support on this .much appreciated.

0 Kudos
Highlighted
Hot Shot
Hot Shot

feb 3

0 Kudos
Highlighted
Hot Shot
Hot Shot

module file

0 Kudos
Highlighted
User Moderator
User Moderator

I seem to have a problem opening that file.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

It’s not complited yet .i just posted for my own reference.will send you a different file .

0 Kudos
Highlighted
Hot Shot
Hot Shot

module file of best features

0 Kudos
Highlighted
User Moderator
User Moderator

This one I can download.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

feb 12 module file

0 Kudos
Highlighted
Hot Shot
Hot Shot

feb21

0 Kudos
Highlighted
Hot Shot
Hot Shot

hc for reference

0 Kudos
Highlighted
User Moderator
User Moderator

I suggest to anonymise a few FQDN in the script :smileygrin:


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Hot Shot
Hot Shot

final report account

0 Kudos