justin_emerson
Enthusiast
Enthusiast

When will PowerCLI support a VIX version above 1.6.2?

Currently, as of PowerCLI 4.0u1, when you try and run Invoke-VMScript (or any of the other intra-guest cmdlets like the ones to set network information) you must have VIX API 1.6.2 installed. This is inconvenient because almost all hosted VMware products (Workstation, Player, etc) come with newer versions of the VIX API installed. You are greeted with this error message:

WARNING: The version of VMware VIX installed on your machine differs from the

recommended one (1.6.2) and may cause VIX-related functionality (e.g. in-guest

operations) to work improperly. We suggest you install VMware VIX 1.6.2.

This is extremely inconvenient for those of us trying to run both hosted VMs and managing VMware infrastructures with the PowerCLI. The VIX API is currently on version 1.8, and there's a 1.10 Beta currently available. In fact, you can't even download the VIX API 1.6.2 from the VIX API webpage. It's only available with the PowerCLI toolkit install.

The PowerCLI should really be updated to support newer versions of the VIX API - at least to version 1.8 which is what comes with Player 3 and Workstation 7.

0 Kudos
2 Replies
justin_emerson
Enthusiast
Enthusiast

Any response on this?

0 Kudos
adrianallan
Contributor
Contributor

I am having the same issues when running any commands related with VMGUEST* - are there any updates?

I really don't want to back level to 1.62 I am currently at 1.8

0 Kudos