sevenply
Contributor
Contributor

VmWare.View.Broker snap-in could not be loaded

I have a problem with VmWare PowerCLI.

After I updatet VMWare View to 5.1 my PowerCLI does not work anymore.

The error messages is:

"Add-PSSnapin : Cannot load Windows PowerShell snap-in Vmware.View.Broker because of the following error:

The Windows PowerShell snap-in module C:\Program Files\Vmware\Vmware View\Server\bin\PowershellServicesCmdlets.dll does not

required Windows PowerShell snap-in strong name PowershellServiceCmdLets, Version=5.0.0.7378, Culture=neutral, PublicJeyToken=null"

Does anyone have the same problem?

Tags (2)
4 Replies
firestartah
Virtuoso
Virtuoso

Hi

have you had a look at this thread? http://communities.vmware.com/message/1747441

Gregg

If you found this or other information useful, please consider awarding points for "Correct" or "Helpful". Gregg http://thesaffageek.co.uk
0 Kudos
LucD
Leadership
Leadership

Works for me. Did you install View in the default directories ?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
bzjeurd
Contributor
Contributor

Hello sevenply,

Yes I do have the same problem after upgrading to View 5.1.

My vCO scripts that use the addPSSnapIn action suddenly failed with this error.

To solve this problem, I run once the following ps script supplied by VMware:

C:\program files\VMware\VMware View\Server\extras\Powershell\add-snapin.ps1

This script in fact register the new PowershellServiceCmdlets.dll installed with the View 5.1 upgrade.

I hope this will be usefull.

Bz

0 Kudos
bcecka
Enthusiast
Enthusiast

I realize this is a little late, but I ran into this today and seem to have fixed it by just running the View PowerCLI shortcut once as an Administrator. After that it started up normally without complaining.