impranayk
Enthusiast
Enthusiast

The module 'VMware.VimAutomation.Sdk' cannot be installed or updated because the authenticode signat

Jump to solution

PowerCLI C:\> Install-Module -Name VMware.PowerClI
PackageManagement\Install-Package : The module 'VMware.VimAutomation.Sdk' cannot be installed or updated because the
authenticode signature of the file 'VMware.VimAutomation.Sdk.cat' is not valid.
At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\2.2.3\PSModule.psm1:9685 char:34
+ ... talledPackages = PackageManagement\Install-Package @PSBoundParameters
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package],
Exception
+ FullyQualifiedErrorId : InvalidAuthenticodeSignature,ValidateAndGet-AuthenticodeSignature,Microsoft.PowerShell.P
ackageManagement.Cmdlets.InstallPackage

 

@LucD Can you please suggest on this error.

------------------------------------------------------------------------- Follow me @ www.vmwareinsight.com Please consider marking this answer "correct" or "helpful" if you found it useful Pranay Jha | Blog: http://vmwareinsight.com vExpert 2016/2017, VCAP5-DCD/DCA, VCP5-DCV, VCA-Cloud, VCE-CIA, MCSE, MCITP
0 Kudos
1 Solution

Accepted Solutions
LucD
Leadership
Leadership

This is a known issue, and easy to resolve.
See the last paragraph in PowerCLI 12.4 – What’s New


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

View solution in original post

3 Replies
LucD
Leadership
Leadership

This is a known issue, and easy to resolve.
See the last paragraph in PowerCLI 12.4 – What’s New


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

impranayk
Enthusiast
Enthusiast

Worked by running this command. Thanks @LucD 

install-module vmware.powercli -scope AllUsers -force -SkipPublisherCheck -AllowClobber

------------------------------------------------------------------------- Follow me @ www.vmwareinsight.com Please consider marking this answer "correct" or "helpful" if you found it useful Pranay Jha | Blog: http://vmwareinsight.com vExpert 2016/2017, VCAP5-DCD/DCA, VCP5-DCV, VCA-Cloud, VCE-CIA, MCSE, MCITP
DCasota
Expert
Expert

Same issue with PowerCLI 12.7 on MS Windows Server 2022. Still -SkipPublisherCheck needed.

PS D:\> install-module -name VMware.PowerCLI -force PackageManagement\Install-Package : The module 'VMware.VimAutomation.Sdk' cannot be installed or updated because the authenticode signature of the file 'VMware.VimAutomation.Sdk.cat' is not valid. At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:1809 char:21 + ... $null = PackageManagement\Install-Package @PSBoundParameters + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidOperation: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package], Exception + FullyQualifiedErrorId : InvalidAuthenticodeSignature,ValidateAndGet-AuthenticodeSignature,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPackage PS D:\> ver
ver : The term 'ver' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ ver
+ ~~~
+ CategoryInfo : ObjectNotFound: (ver:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

PS D:\> cmd
Microsoft Windows [Version 10.0.20348.825]

0 Kudos