pamiller21
Enthusiast
Enthusiast

Storage vMotion vCLS VMs

I have built a little script to tag and take care of these little vCLS VMs whenever they appear, but I can't get them to storage vMotion from off my ISO repo to my production iSCSI SAN because when you storage vMotion via the webui it ask for a confirmation and when I run this portion of the script it says the following:

Line 5 | Move-VM -VM $VM -Datastore $RDCDatastoreCluster
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| 5/28/2021 10:59:48 PM Move-VM A specified parameter was not correct: StoragePlacementSpec.vm
Move-VM:

Is there anyway around this?

0 Kudos
11 Replies
LucD
Leadership
Leadership

The same error was also reported in Duncan's VMware vSphere Cluster Services (vCLS) considerations, questions and answers post.

Same advise here, open an SR.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
rkabelich
Contributor
Contributor

For all, playing around the same issue:

vMotion both, Storage and Compute, should migrate the vCLS VMs to different Datastores.

singhrobin
VMware Employee
VMware Employee

It better you select "Allowed Datastore" which will be use to auto deploy vCLS VMs.

To configure this, go to:
vsphere Cluster -> Configure  -> vSphere Cluster Service -> Datastores -> Click "Add" and select preferred Datastore.

 

Thanks,
Robin Singh

depping
Leadership
Leadership


@singhrobin wrote:

It better you select "Allowed Datastore" which will be use to auto deploy vCLS VMs.

To configure this, go to:
vsphere Cluster -> Configure  -> vSphere Cluster Service -> Datastores -> Click "Add" and select preferred Datastore.

 

Thanks,
Robin Singh


that feature is not available in the current release Robin? i think you are talking about a feature which may get released in the future 🙂

0 Kudos
chris_olsen
Contributor
Contributor

Hello,

That option looks like exactly what I'm needing to do (we're moving off an old storage cluster onto a new one and need to storage vMotion the vCLS VMDKs over to another datastore).  That said, like the previous respondent noted, I don't see that option in the vSphere Cluster configuration tab.  Running vSphere 7.0u2c

Thanks!

Chris

Tags (1)
0 Kudos
depping
Leadership
Leadership

It doesn't exist, it is scheduled for the next release 🙂

0 Kudos
chris_olsen
Contributor
Contributor

Ah so - thanks.  I saw that in your earlier response and couldn't tell if it was wishful thinking or a prediction.  We're about to roll out 7.0U2d due to that last exploit - do you know if it got bundled into that?

Thanks again,

Chris

0 Kudos
depping
Leadership
Leadership

No it is not, i am talking about a proper release, not a patch release 🙂

0 Kudos
cdsharp
Contributor
Contributor

I just installed the patch and the function is there. I have verified it works. I was able to migrate the vCLS vms.

0 Kudos
rkabelich
Contributor
Contributor

Yes, since VCSA 7.0.3.0 (18700403) the option is available. 

0 Kudos