zare_N0222
Enthusiast
Enthusiast

Some problem with instaling plugin on vCSA

Hi ,

hopes you all well .

I am trying to install a plugin for vRNI on vCSA. But I getting an error .  Aldo on the end there is a message that plugin is installed on vCSA , plugin isn't  show .A restarted services and vCSA just in case.

A try with different versions but the same result. ( PS version 5.1 , 7.1 and 6.2.4). It seams to be a problem with cert.

could someone help me?

\install-vrnivsphereplugin-v1.0.0.ps1 -Operation Install

Downloading vRealize Network Insight vCenter Plugin from URL: https://network-insight-vcenter-plugin.s3-us-west-2.amazonaws.com/vrni-plugin-vcenter-v1.0.0.zip

You cannot call a method on a null-valued expression.

At D:\_scripts\vRNI_plugin\install-vrnivsphereplugin-v1.0.0.ps1:101 char:5

+     $certBytes = $Certs[-1].Certificate.GetRawCertData()

+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo          : InvalidOperation: (:) [], RuntimeException

+ FullyQualifiedErrorId : InvokeMethodOnNull

Multiple ambiguous overloads found for "ComputeHash" and the argument count: "1".

At D:\_scripts\vRNI_plugin\install-vrnivsphereplugin-v1.0.0.ps1:102 char:5

+     $hash = $sha256.ComputeHash($certBytes)

+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo          : NotSpecified: (:) [], MethodException

+ FullyQualifiedErrorId : MethodCountCouldNotFindBest

Exception calling "ToString" with "1" argument(s): "Value cannot be null.

Parameter name: value"

At D:\_scripts\vRNI_plugin\install-vrnivsphereplugin-v1.0.0.ps1:103 char:5

+     $thumbprint = [BitConverter]::ToString($hash).Replace('-',':')

+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo          : NotSpecified: (:) [], MethodInvocationException

+ FullyQualifiedErrorId : ArgumentNullException

SSL Thumbprint:

Press any key to continue or CTRL+C to quit:

vRealize Network Insight Plugin installed to vCenter!

One more thing; to keep track of the usage of this plugin, we would like to know some details (vCenter version, and the number of VMs & Hosts). Can I phone home? No hard feelings, if not. 🙂

Phone home? (Yes/No): n

pastedImage_7.png

0 Kudos
5 Replies
LucD
Leadership
Leadership

That script is part of a Fling, so no official support I'm afraid.

It seems you already reported this same error in the Comments section of that Fling.
Perhaps it would be better to wait for a reply from the authors of the Fling, instead of cross-posting.

The script produces some output while running, that you apparently didn't include that.

I suspect that the script isn't able to capture the certificate from the plugin, which the missing thumbprint in the output seems to confirm.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
zare_N0222
Enthusiast
Enthusiast

hi LucD,

you are right. I will wait.

Output I didn't show

pastedImage_0.png

I'm posting here because it seems like the plugin is installed and not shown in CSA. maybe something can change in my environment .

0 Kudos
LucD
Leadership
Leadership

Did you already check some of the remediations Martijn gave in the comments?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
zare_N0222
Enthusiast
Enthusiast

yes. I try with a different version, check DNS and access to internet .

0 Kudos
LucD
Leadership
Leadership

Then wait for a reply from Martijn.

You could ping him on VMware{code} Slack


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos