Snapshot is in powered off state

Jump to solution

Hi All,

If I take snapshot (123) manually, I found it in powered on state. But If I take snapshot (456) using PowerCLI, I found it in powered off state as below:

123.JPG

I ran the command -  "New-Snapshot 2003C -Name 456" in PowerCLI. Am I missing any parameter to switch the snapshot on? Please help me to fix it.

I'm using the below:

vSphere 5.1 build 880146

PowerCLI 5.0 build 435427

Thanks,

Ganesh

~GaneshNetworks™~ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos
1 Solution

Accepted Solutions
drivera01
Enthusiast
Enthusiast

don't you have to use the "memory" parameter?

do: help new-snapshot -detailed

  
   -Memory
       If the value is $true and if the virtual machine is powered on, the virtual machine's memory state is preserved with the snapshot.

View solution in original post

0 Kudos
2 Replies
drivera01
Enthusiast
Enthusiast

don't you have to use the "memory" parameter?

do: help new-snapshot -detailed

  
   -Memory
       If the value is $true and if the virtual machine is powered on, the virtual machine's memory state is preserved with the snapshot.

0 Kudos

Oops! I totally forgot the memory piece.

Also, I referred only examples of new-snapshot only, which does not have this memory switch anywhere. Thank You!

~GaneshNetworks™~ If you found this or other information useful, please consider awarding points for "Correct" or "Helpful".
0 Kudos