Highlighted
Enthusiast
Enthusiast

Set-CDDrive Connection control operation failed for disk 'ide0:0'

Jump to solution

Hello,

I get an error when trying to connect an ISO file to a VM.

Just assigning the ISO file works fine. But as soon as I want to connect the ISO, I get this same error message.

Get-VM -Name VMName | Get-CDDrive | Set-CDDrive -IsoPath '[DataStoreName] Iso/Windows/2019/Win2019.ISO' -Connected $true

Set-CDDrive : 12/07/2019 12:11:20 Set-CDDrive Server task failed: Connection control operation failed for disk 'ide0:0'. Connection control operation failed for disk 'ide0:0'.

At line:1 char:40

+ ... t-CDDrive | Set-CDDrive -IsoPath '[DataStoreName] Iso/Windows/2019 ...

+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Set-CDDrive], VimException

    + FullyQualifiedErrorId : Security_Impl_TaskResultConverter_TaskNotSucceeded,VMware.VimAutomation.ViCore.Cmdlets.Commands.VirtualDevice.SetCDDrive

I also get the same error message when I do it with the remote console or with the vSphere Client web site.

Tags (1)
1 Solution

Accepted Solutions
Highlighted
Enthusiast
Enthusiast

Hi Luc,

My apologies! The path was wrong. I forgot it's a Linux system which is case sensitive.

But the fact that it accepts the -IsoPath parameter without checking the path is missleading...

Only when you use the -Connected parameter it shows you that something is wrong.

Thanks for taking from your time to help me!

By the way, how do you highlight your syntax? PowerShell is not among the liste languages...

_____________________________________________________________________________

Was it helpful? Let us know by completing this short survey here.

View solution in original post

0 Kudos
4 Replies
Highlighted
User Moderator
User Moderator

Can you try to remove/add the CDDrive to the VM?

Get-VM -Name VMName | Get-CDDrive | Remove-CDDrive -Confirm:$false

Get-VM -Name VMName | New-CDDrive -Confirm:$false

I have the impression there is something fishy with that CDDrive.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi Luc,

My apologies! The path was wrong. I forgot it's a Linux system which is case sensitive.

But the fact that it accepts the -IsoPath parameter without checking the path is missleading...

Only when you use the -Connected parameter it shows you that something is wrong.

Thanks for taking from your time to help me!

By the way, how do you highlight your syntax? PowerShell is not among the liste languages...

_____________________________________________________________________________

Was it helpful? Let us know by completing this short survey here.

View solution in original post

0 Kudos
Highlighted
User Moderator
User Moderator

When you use Visual Studio Code, you can just copy/paste your code.

On the missing check, I would suggest to launch an idea on the PowerCLI Ideas website.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thank you!

I have done what you suggested: Set-CDDrive validates path | VMware PowerCLI

By the way, I just joined the VMware community to ask my very first question.

However, you already helped me a lot before that because you answered so many questions here...

Thank you Luc for all the help you are providing to me but also to the community since all those years 🙂