naiksidd
Enthusiast
Enthusiast

Rename Portgroup give error, "Unexpected error checking compliance: 'None Type' object has no attribute 'checkBeacon' "

Hello,

I am using a script in my environment which renames PortGroup

what I do is "$PortGroup | Set-VirtualPortGroup -Name $pgNameNew -VLanId $vlanID | out-null"

the command goes fine, when I check the profile it shows not compliant (as expected).

then I used same command and renamed the PortGroup back to orignal name and check compliance,

this time it gives error "Unexpected error checking compliance: 'None Type' object has no attribute 'checkBeacon' "

the same process done via GUI works fine.

Any Idea , what am I missing here?

All the hosts are on 5.1

regards,

Siddharth Naik

Tags (1)
8 Replies
LucD
Leadership
Leadership

Did you do the compliance check from the Gui or with PowerCLI ?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos
naiksidd
Enthusiast
Enthusiast

Hi Luc,

I did the compliance check from GUI.

Both the times.

0 Kudos
naiksidd
Enthusiast
Enthusiast

Guys any pointers where I should look?

0 Kudos
WillFulmer
Enthusiast
Enthusiast

Same issue here. Any resolution?

Unexpected error checking compliance: 'None Type' object has no attribute 'checkBeacon'

0 Kudos
KGadowski
Enthusiast
Enthusiast

Try rebooting the host and running compliance check again. It worked for me - my host is not compliant with the host profile.

0 Kudos
Engelsman
Enthusiast
Enthusiast

I had the same issue after configuring CDP on some hosts. Turned out that I had not enabled CDP on all hosts in the cluster. After enabling CDP on all my hosts' vswitches the profile compliance was fine.

OFcourse you can also choose to disable CDP on all hosts

Example how to enable cdp on your hosts' vSwitch via powercli:

$esx = get-vmhost "myesx"

$myesxcli = get-esxcli -vmhost $esx

$myesxcli.network.vswitch.standard.set("both","1500","vSwitch0")

0 Kudos
JudyR
Contributor
Contributor

I had the same issue, in the vSphere Client, all I had to do was hit 'refresh' in the Networking tab - ran check compliance and Host was now compliant.

bsd1977jda
Contributor
Contributor

Refresh worked for me as well JudyR, thanks!

0 Kudos