Highlighted
Enthusiast
Enthusiast

Problems connecting

Jump to solution

Guys,

I've just started playing around with powershell. I have PowerCLI installed on directly on the vCenter. I login to vCenter server (Windows 2008 Server) using RDP and open the PowerCLI prompt and run the following command

Connect-VIServer server (I use thr FQDN).

It never failed to connect however I have just started receiving the followig errors when I try to connect

"Could not connect using the requested protocol".

As far as I'm aware nothing has changed and I dont know why its not workionganymore.

Any suggestions?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

This is probably due to your proxy settings.

Use the following cmd to set your powercli to bypass the proxy and try connecting again:

Set-PowerCLIConfiguration -Proxy "NoProxy"

Arnim

Arnim van Lieshout Blogging: http://www.van-lieshout.com Twitter: http://www.twitter.com/avlieshout If you find this information useful, please award points for "correct" or "helpful".

View solution in original post

0 Kudos
4 Replies
Highlighted
User Moderator
User Moderator

It might be that one of the VMware services is not running on the vCenter server. Probably the "VMware VirtualCenter Management Webservices" service.

Regards, Robert

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition
0 Kudos
Highlighted
VMware Employee
VMware Employee

This is probably due to your proxy settings.

Use the following cmd to set your powercli to bypass the proxy and try connecting again:

Set-PowerCLIConfiguration -Proxy "NoProxy"

Arnim

Arnim van Lieshout Blogging: http://www.van-lieshout.com Twitter: http://www.twitter.com/avlieshout If you find this information useful, please award points for "correct" or "helpful".

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

How to no prompt for below command

Set-PowerCLIConfiguration -ProxyPolicy NoProxy:  its asking Yes ,ALL... options

I want default as Yes

0 Kudos
Highlighted
User Moderator
User Moderator

Did you use the -Confirm:$false switch?

If not, the cmdlet will ask for confirmation.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

0 Kudos