stephenmbell
Enthusiast
Enthusiast

Open-VMConsoleWindow -- Having issues

Hello Community -

I am hoping someone here can point me in the right direction.  I had to rebuild my laptop recently and I haven't been able to figure this out.  Prior to the crash - I was able to run get-vm myVirtualMachine | open-vmconsolewindow    and this would open up in my browser.

A while back I had an issue when Chrome stopped supporting NPAPI - so I had to use Set-PowerCLIConfiguration to set my VMConsoleWindowBrowser to be Firefox.  Once set - this worked fine for months.

Now that I had to reinstall everything I can't seem to get past (in Firefox) - I run the command and I see a "tap here to activate the plugin".  Once I do, I click Allow and Remember - and my browser just stops at a white screenpowercli.PNG

Any help or direction with this issue would be greatly appreciated as I would prefer to stay out of the web client or windows client as much as possible.

Thanks,

sb

7 Replies
LucD
Leadership
Leadership

Is the VMRC plugin installed for FireFox?

Normally that is installed during the PowerCLI installation, but if you installed FF later on, that plugin might be missing.

You can uninstall/install the VMRC sw separately.

See Opening the Virtual Machine Remote Console through PowerCLI for some more info more specifically the How does this work under the covers? section.


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

stephenmbell
Enthusiast
Enthusiast

Thank you for the reply.  I first re-installed the VMRC from the vcenter web client.  This didn't do the trick, so then, I uninstalled Firefox, uninstalled PowerCLI, rebooted, installed Firefox, installed PowerCLI -- still seeing the same thing. 

I installed Firefox 48.0.2. and VMware vSphere PowerCLI 6.3 Release 1 build 3737840

I am running vcenter 6.0.0 3634793 with esxi 6.0.0 4192238

I feel like I shouldn't be struggling with this as much as I am.  I have to be missing something?!?!

Any guidance is appreciated.

sb

0 Kudos
VMGeneral
Contributor
Contributor

‌Hi

What version of Firefox are you using? It requires a 32 bit version.

stephenmbell
Enthusiast
Enthusiast

Thanks for the reply.

Just checked - the .exe is located in Program Files (x86).

-Steve

0 Kudos
LucD
Leadership
Leadership

Have you already checked out KB2091284?


Blog: lucd.info  Twitter: @LucD22  Co-author PowerCLI Reference

stephenmbell
Enthusiast
Enthusiast

Thanks for all of the input - I was finally back in the office today and able to verify.

Reinstalling after an install of Firefox seemed to resolve my issue.

Thanks again

sb

0 Kudos
Groffskiii
Contributor
Contributor

I had this same issue and it had persisted through an uninstall and re-install of both Firefox and PowerCLI. Granted I do not remove the settings files that firefox leaves after an uninstall.

The solution for me was simply open Firefox and opened:


Add-Ons > Plugins > VMware Remote Conse Plug-in > set to "Always Activate"

0 Kudos